Support » Fixing WordPress » Version 3.1.2 causes problems in administration

  • I just updated to WordPress version 3.1.2. When I’m working in the administration application I’m periodically getting kicked out to the log-in screen (wp-login.php?).
    – –
    For instance, I’m editing an entry. I click on “Preview.” I go there fine. But when I do a refresh, it tells me “You do not have permission to preview drafts.” I return to my editing window. I click on “Preview”. I’m taken to the administration log-in screen. I log in and I’m at the dashboard. I click on “View” for the post I want to preview. At the top I have a menu option of “Editing Post” I click on that — I go to the log-in screen.
    – –
    Another example. I’m editing an entry. I click on the plug-in icon. I’m kicked out to the admin log-in screen.
    – –
    Any ideas what’s up?

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Esmi — Thanks for the suggestions. Deactivating the plug-ins didn’t work. When I switched to Twenty Ten, it worked fine. Interestingly, once I switched back to the original theme, the problem no longer existed. (I’m glad about that: I’m using an adapted default them, changed to match the look of my website — I wouldn’t even know where to begin to trouble shoot the theme.) One of the elements of my theme did need to be adjusted — the navigation bar was no longer in the correct place.

    Hmm, I’m going to leave this open for awhile. It worked fine for awhile, then started kicking me out of administration again. De-activating the plug-in “Add Meta Tags” seems to fix it — but I’d like to have it work for a few days before I say resolved.

    Yesterday everything was working fine. Today when I logged in, again I would get kicked out to the log-in screen. I changed to twenty-ten. Still got kicked out. De-activated plug-ins (yes, the same plug-ins that were activated all day yesterday when it worked just fine). Now, no problem, even changing back to my adapted Default theme.
    – –
    After I activated the plug-ins again; still works
    – –
    What’s up? Why does it work one day then the next day, when I’ve made no changes, I again get kicked out to the log-in screen. After I change themes, deactivate plug-ins, restore theme, restore plug-ins it again (right now is working).
    – –
    Can any one suggest a permanent fix or tell me what’s going on here?

    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Version 3.1.2 causes problems in administration’ is closed to new replies.