Support » Plugin: Twitget » Version 3: all settings still being reset to "A"

  • Resolved


    The post here is marked as resolved because version 3 of the plugin should have fixed the issue:

    but I am using version 3 and the issue persists. I can input correct data and get the plugin working, but then after a couple minutes all fields get reset to “A” and all the checkboxes get checked.

    I’ve tried completely deleting and reinstalling the plugin with no success. I also installed the plugin into a new, 2012-themed version of WordPress with the same issue.

    A little more detail on the issue:
    If I install the plugin and set up the correct info, it fails initially as it apparently waits for the twitter feed refresh (which is fine since it only happens initially). After the refresh happens, the plugin starts to work correctly and I can see tweets. However, after I refresh the page a second time, the tweets are replaced by “Twitter outputted an error: A.” Then, when I log back into the WordPress backend, all the fields have the letter “A” in them and all the checkboxes are checked. Subsequent attempts to to re-enter the correct information fails to save as it get’s overwritten with the “A”s. The only way to get input to stick again is to deactivate/reactivate or uninstall/reinstall the plugin, which starts to whole process over again.

    I work for a development firm and we have been using Twitget on a lot of the websites we build, so I hope this can get resolved so we don’t need to switch to an inferior plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Bostjan Cigan


    Hey Tomas,

    Is there any way you could give me a test WP installation on your server so that I could debug it there? With your Twitter data feed?

    I’ve found out that this occurs to some people, but never found out why exactly. I though I’ve eradicated this error, but looks like it’s still there.



    I work with Tomas and I think I have tracked down the issue to some extent.

    I noticed that after the first refresh of twitter data the wp_options table record for twitget_settings in the option_value column, data is getting truncated. Therefore the primary plugin settings are no longer in the table and the data itself is no longer able to be parsed.

    It seems in our case this is due to a few emoticon chars in the twitter data.
    i.e: 🇺🇸🇺ðŸ‡

    It appears that the data truncates after these chars. It looks like it’s in the twitter_status method when it fires: update_option(‘twitget_settings’, $options);

    I think it’s mostly due to the WP update_option method, as it does a lot of sanitizing and filtering on the data. I have checked the data that is passed into this method and it appears to be fine. But when it get’s to the database it’s not.

    My suggestion would be to remove the ‘caching’ of the twitter data from the options table. Perhaps fire up a twitget table to store data, or cache it in a local file. I think it would prevent the plugin settings from suffering any run time issues.

    The letter ‘A’ appears to be the first char of the data, and because it is malformed and cannot be parsed it appears in all the fields that rely on the options data, as well as the visual error you see on the UI side.

    I’m sure some of this you may already know, but hopefully I have given you some additional info to work with. I may experiment a bit with the code to try to isolate the twitter data. Happy to share all info with you to keep this awesome plugin working!

    Plugin Author Bostjan Cigan


    Hello thorak01, haven’t known about this, at first I though the error was caused by something else entirely, but you’ve given me more info. It seems the serialization of the data causes this just like you’ve said.

    I’ll fix it as soon as I come from vacation 🙂


    I have also encountered the same problem; seemed to initiate when I attempted to insert a “ ” (for an extra space) in the custom html output box. A deletion/re-install of the plugin resolved it . . . have had no repetition to this point. (Will report if it happens again.)

    Thank you for providing an excellent plugin, free-of-charge, regardless.

    Plugin Author Bostjan Cigan


    OK, please test it in version 3.1 (when commited).

    I’ve tried a bunch of “funky” characters and they worked without resetting any data.


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Version 3: all settings still being reset to "A"’ is closed to new replies.