Support » Plugin: WordPress Related Posts » Version 3.6.4 broke my site

  • Resolved Fernando Tellado

    (@fernandot)


    I’ve just updated to 3.6.4 and my site broke. I’ve downgraded and everything is ok again.

    WP last version, PHP 7.0, SiteGround Hosting

    It’s an Parse error: syntax error unexpected in plugin config file

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Sovrn

    (@sovrn)

    Hi @fernandot,

    Thanks for reaching out to us here at sovrn support and we apologize for any issues that you are experiencing!

    To help our engineers investigate the problem, can you provide us with more detail about the breakage you encountered? Are you currently using any other custom settings on your site? If you could email us directly at ea-support@sovrn.com we would love to help you troubleshoot further! Any additional information would be helpful and very much appreciated.

    Best,
    Sovrn Support

    ande1352

    (@ande1352)

    Same issue for me. broke my site, a downgrade quickly fixed it.

    Plugin Author Sovrn

    (@sovrn)

    Hi @ande1352,

    We apologize for this inconvenience!

    If you could reach out to us directly at ea-support@sovrn.com with as much detail as possible about your breakage that would be incredibly helpful. Are you currently using any other custom settings on your site?

    Best,
    Sovrn Support

    The exact message is this:
    Parse error: syntax error, unexpected '[', expecting ')' in /path_to_server/wp-content/plugins/wordpress-23-related-posts-plugin/config.php on line 130

    Plugin Author Sovrn

    (@sovrn)

    We’ve found the problem.

    Our latest plugin update, 3.6.4, will not work properly with sites on PHP 5.3.* or older. It requires PHP 5.4 or higher to function properly. 99.9% of our users meet this PHP requirement, but a few users are on PHP 5.3.* or older and are encountering problems.

    If your site runs on the older PHP 5.3.* you can still use our previous plugin version, v3.6.3, without problem. It can be downloaded directly from WordPress at: https://wordpress.org/plugins/wordpress-23-related-posts-plugin/advanced/

    We apologize for the inconvenience this has caused some of you, and want to thank you all for helping us in discovering and diagnosing the problem.

    Today we will update our readme to list PHP 5.4 or newer as a requirement for our future plugin updates. Additionally, we will build in functionality for the plugin that checks PHP version on activation and only allows activation to complete if the minimum PHP version is running on the site (if an older PHP version is detected, it will display a message directing users to our plugin version 3.6.3).

    Thank you for your understanding and help.

    Sovrn Support

    As I told you I have php v7 installed in the server. v 7.0.1.6 to be exact

    Plugin Author Sovrn

    (@sovrn)

    Hi @fernandot,

    If you could reach out to us directly at ea-support@sovrn.com with as much information as possible we would love to help you troubleshoot the issue further. Screenshots are extremely useful in helping us to understand the root of the problem. Your error looks to be the only one that we have received outside of the outdated PHP compatibility problems so we would love to take a deeper look.

    We appreciate your patience and apologize again for the inconvenience.

    Best,
    Sovrn Support

    Check your email 😉

    thanks

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Version 3.6.4 broke my site’ is closed to new replies.