• As I wrote, version 3.6 20220927 breaks the entrance to the admin panel:

    Causes an error: “[27-Sep-2022 19:07:27 UTC] PHP Warning: Cannot modify header information – headers already sent by (output started at /home/m/……../………/public_html/wp-content/plugins/telegram-bot/panel/send.php:67) in /home/m/………./………/public_html/wp-includes/pluggable.php on line 1424”

    Incorrect operation of the php script. The problem was caused by the presence of BOM characters in one or more script files on my site

    • This topic was modified 1 year, 9 months ago by Serdobolniy.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Marco Milesi

    (@milmor)

    Hi @serdobolniy,
    i just released v3.6.1 to address this issue. Please let me know if the warning has been solved.

    Best regards,
    Marco

    Thread Starter Serdobolniy

    (@serdobolniy)

    Everything is great! For the first time I meet such a fast support, 5 minutes after the reported error 🙂 I understand that the author of the plugin himself noticed it and apparently corrected it at the time I wrote the comment. But it’s still nice to think that the problem was solved after 5 minutes 🙂 Thank you!

    But when updating version 3.6 to 3.6.1, the following message popped up (just adding (problem solved)):

    Update failed: {“success”:true,”data”:{“update”:”plugin”,”slug”:”telegram-bot”,”oldVersion”:”\u0412\u0435\u0440\u0441\u0438\u044f 3.6″,”newVersion”:”\u0412\u0435\u0440\u0441\u0438\u044f 3.6.1″,”plugin”:”telegram-bot\/telegram-bot.php”,”pluginName”:”Telegram Bot & Channel”}}

    I just refreshed the page, after the received message and the version was applied, the admin login now works.

    Plugin Author Marco Milesi

    (@milmor)

    Hi and thank you!
    I can confirm i fixed the bug after your issue, i wasn’t aware of the problem before 🙂

    Just as an advice: evaluate whether or not to hide php warnings from the website: it can lead to security issue sometimes by revealing internal paths on the frontend website.

    Thanks for the review edit and please let me know if you need further assistance!

    Best regards,
    M.

    Thread Starter Serdobolniy

    (@serdobolniy)

    In that case, this is the best support I’ve ever met.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Version 3.6 20220927 breaks the entrance to the admin panel’ is closed to new replies.