Support » Plugin: WooCommerce » Version 3.6.2 destroys affiliatelinks on single productpage button

  • Resolved Breinbrouwsels

    (@breinbrouwsels)


    The latest version Woocommerce 3.6.2. brings my Awin affiliate links still to the right landingpage from the button on category pages but goes to the homepages from the button on single product pages. It is the same deeplink on both buttons that I inserted in the external link field.

    Ter are no problems with the affiliatelinks from other networks then Awin as far as I can see.

    With the version 3.6.1 there are no problems of this kind.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • I have the same problem.

    Same kind of problem with affiliatelinks to TradeTracker.

    But not only to the homepage of the advertiser but also landing on the Ooops! page of TradeTracker witch means that there is no connection with the advertiser at all!

    RED ALERT!
    There are thousands of affiiate marketeers who are not aware of this faillure that kills our business!
    Wake up Woo!!

    • This reply was modified 2 months, 3 weeks ago by  Breinbrouwsels. Reason: RED ALERT
    Plugin Support RK

    (@riaanknoetze)

    Hi there,

    I’ve re-read the posts here a few times but I’m at a loss as to what’s happening here. Would you mind elaborating a bit on what’s going?

    If you have actionable steps on how to replicate that on my local testing installation – that’d be super helpful. Alternatively, if you have any screenshots – that’d be great 🙂

    Thanks!

    Plugin Support RK

    (@riaanknoetze)

    Just noticed there’s a duplicated thread open at https://wordpress.org/support/topic/affiliate-url-stopped-working/

    Closing this one for now.

    1. Here is the link to the homepage of lillikurt.nl
    https://lillikurt.nl
    2. Find a deeplink with ‘awin’ from the network Awin/Zanox in it at the bottom of your screen by going over the buttons with your cursor. E.g. the 2e one. Klick the button and find out that the link sent you to the correct landingspage.
    3. Go back to the homepage on lillikurt.nl and click on the productimage from the product you clicked on 2. and then click on the button to find yourself arriving on te homepage of the advertiser instead of on the productpage you landed on 2.

    There are also issues with deeplinks from TradeTracker and TradeDoubler.

    Regards,
    Bert Peters

    Also affiliate deeplinks on single product page buttons from Bol.com are effected.
    They work perfect on category pages but from the single product pages they are landing on the homepage of the advertiser.

    Woocommerce 3.6.2 changes the external links. There are differences as far as I an see in the ‘&amp’ or ‘;’.

    I changed status to Not Resolved.

    I went back to version 3.6.1 by downloading it from Github and it works fine now.

    Download 3.6.1 https://github.com/woocommerce/woocommerce/releases/tag/3.6.1

    I could not find the version in Dutch so it was the English version.

    de-activate 3.6.2 and activate 3.6.1

    I should not have removed 3.6.2 after that but leave it there deactivated to keep translations.

    This works. Thanks!

    • This reply was modified 2 months, 2 weeks ago by  cloudduster.

    OK

    hope they will resolve this in 3.6.3

    Breinbrouwsels

    (@breinbrouwsels)

    Using now version 3.6.1 I discovered that deeplinks that are shortened and activated with the Gotocard button on a single productpage will not land on the target page with the advertisers website but on an empty page with the warning:

    Firefox kan geen verbinding maken met de server op tidd.ly.

    On the categorypage it works fine.

    This notification is a supplement to the previous problems that occurs using the last update version 3.6.2 from Woocommerce.

    Breinbrouwsels

    (@breinbrouwsels)

    This might have something to do with this problem:

    https://wordpress.org/support/topic/external-product-url-tags-are-stripped/

    Breinbrouwsels

    (@breinbrouwsels)

    Problems are solved in 3.6.3 Thanks

    Only problem is the thing with that linkshortener I mentioned before.
    That might be a prolem with http to https(?).

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    Thanks for letting us know this is solved in 3.6.3!

    I’m not seeing anything specifically related to it in the changelog, though:
    https://github.com/woocommerce/woocommerce/blob/3.6.3/CHANGELOG.txt

    Breinbrouwsels

    (@breinbrouwsels)

    Hello Hanna S.

    Maybe this one:
    * Fix – Error in the logic used to build fields for external products when the query string contained full-stops, pluses or spaces in the values of the parameters. #23535

    Plugin Support Hannah S.

    (@fernashes)

    Automattic Happiness Engineer

    @breinbrouwsels – that’s exactly it, thanks for spotting it and sharing!

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.