Support » Plugin: Simple Calendar - Google Calendar Plugin » Version 3.1.11 causes error

  • Resolved vultan

    (@vultan)



    Simple Calendar was working great for me, then I did the upgrade to 3.1.11; now I get this error:

    Fatal error: Call to undefined function GuzzleHttp\Handler\curl_reset() in /home/oremetor/public_html/wp2/wp-content/plugins/google-calendar-events/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 78

    The whole website is now dead, unless I disable the plugin. Any suggestions?

Viewing 9 replies - 16 through 24 (of 24 total)
  • G P

    (@wetapplemedia)

    Currently, NO version works with PHP 7.2!

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @wetapplemedia

    As mentioned in the other thread, we’re working on a fix so that the plugin is compatible with 7.2.

    Thank you again for reporting the bug & for posting your workaround in the meantime.

    Regards,

    Zach

    Zach, thanks for the 3.1.11.1 fix. I’ve got two websites I’m using this on; on the one I had already upgraded to PHP 5.5.13, it installed without a problem. On the site running PHP 5.4.13, it refused to activate until I upgraded PHP, which I did. So on my end, everything is now working as it should. Thanks so much for the quick response.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @vultan

    I’m very happy to hear that. Please don’t hesitate to reach out if you run into other problems.

    Regards,

    Zach

    Hello,
    Après la nouvelle mise à jour, Voici ce que me répond OVH, premier hébergeur en France:

    Simple Calendar could not be activated.
    Required PHP version: 5.5 – Version found: 5.4.45
    Please update to meet Simple Calendar requirements.

    Version 3.1.10 is only 816 files while the latest version 3.1.11.1 is over 7500 files. What is the cause of this massive increase and can this be restored?

    Hi @oxymoron

    The fix for 3.1.11.1 prevents the plugin to activate for those of us with older versions of PHP. It does prevent the crash. Are there plans to address the older versions of PHP so that the plugin will install and work as before? Unfortunately I am on a hosting package and can’t change the PHP version.

    Regards, Bob

    Plugin Author Zach Wills

    (@oxymoron)

    @hjsurk

    The increase in files is because of the update to the Google API PHP Client Library v2 (https://github.com/google/google-api-php-client).

    @rkovacs123 & @webxwebywebz

    In the meantime, you can download and run version 3.1.10 from here: https://downloads.wordpress.org/plugin/google-calendar-events.3.1.10.zip

    The new requirements for PHP 5.5 stem from upgrading the Google API PHP Client Library to v2. We are reviewing our decision to make that update and deciding whether or not it makes sense to roll back the library version used in the plugin to the previous one (which is compatible with older PHP versions).

    Regards,

    Zach

    • This reply was modified 10 months, 3 weeks ago by  Zach Wills. Reason: Tagging correct username

    Hello. Just tried to do the 3.1.11.1 update and getting the same

    Update Failed: Internal Server Error

    Any ideas?
    I’m running PHP 5.6

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Version 3.1.11 causes error’ is closed to new replies.