Support » Plugin: Simple Calendar - Google Calendar Plugin » Version 3.1.11 causes error

  • Resolved vultan

    (@vultan)


    Simple Calendar was working great for me, then I did the upgrade to 3.1.11; now I get this error:

    Fatal error: Call to undefined function GuzzleHttp\Handler\curl_reset() in /home/oremetor/public_html/wp2/wp-content/plugins/google-calendar-events/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 78

    The whole website is now dead, unless I disable the plugin. Any suggestions?

Viewing 15 replies - 1 through 15 (of 24 total)
  • My site went down too – well, the content would not display – with the latest version of this plugin. Had to figure it out by trial and error (turning off all plugins then back on one by one) that it was this plugin.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey all,

    Sorry to hear you’re having trouble with the latest release of the plugin. In the meantime, you can download the last version (3.1.10) from this URL: https://downloads.wordpress.org/plugin/google-calendar-events.3.1.10.zip

    Do you happen to know what version of PHP you’re running? This update bumps the minimum required PHP version to 5.4.

    @giesemedia: can you confirm whether or not the error that @vultan reported is the same one you are getting on your site?

    Thank you both for helping to make Simple Calendar better by reporting issues you find- we’ll do our best to get this fixed for you ASAP.

    Regards,

    Zach

    Thanks for the quick response, @oxymoron. I’m running PHP 5.4.13 here.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @vultan

    No problem- sorry you’re running into issues with the plugin.

    Is it possible to upgrade your PHP version? Our testing for PHP 5.4 and this release was on PHP 5.4.45.

    A quick search about that error shows a potential workaround that may get curl_reset() to work in an older version of PHP:

    https://stackoverflow.com/a/40544743

    If possible, upgrading the version of PHP on your server would be ideal. WordPress strongly recommends running PHP version 7.2 (https://wordpress.org/about/requirements/).

    Another alternative is to use version 3.1.10 of Simple Calendar. We are looking into releasing a hotfix to prevent the latest version from breaking older versions of PHP.

    Let me know if you have any other questions.

    Regards,

    Zach

    Hey Zach-

    I am running PHP 5.4.45 on my EC2 instance and trying to setup this plugin for the first time on my site. I get this error in my httpd error_log after trying to save a new calendar with a valid Calendar ID. For me, it does not break the whole site, but when I go back into the calendar to edit it, I don’t see the “Calendar Settings” section at the bottom of the page, just the title and description. I’ve X’ed out the client IP and actual website address from the log message:

    [Wed Jan 03 02:41:07.697832 2018] [:error] [pid 31112] [client XXX.XXX.XXX.XXX:54731] PHP Fatal error: Call to undefined function GuzzleHttp\\Handler\\curl_reset() in /var/www/html/wp-content/plugins/google-calendar-events/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 78, referer: http://MYWEBSITE.COM/wp-admin/edit.php?post_type=calendar

    I was very encouraged to see your responses this evening on this issue. Thank-you for your time on this!

    • This reply was modified 6 months, 2 weeks ago by  Mike Malburg.
    Plugin Author Zach Wills

    (@oxymoron)

    Hey @mikemalburg,

    Thank you for the detailed report!

    It looks like our testing on PHP 5.4.45 either had a patch for that missing function or wasn’t tested thoroughly enough. I’m going to check with the team so we don’t run into a similar issue in the future.

    We’ll work on our end to both update the minimum required version mentioned in our docs to PHP 5.5 (according to the PHP docs: http://php.net/manual/en/function.curl-reset.php) as well as implement something to prevent older versions from breaking when using the plugin.

    Is it possible for you to use an updated version of PHP? If not, I mentioned to @vultan in my last reply that there is a potential workaround for that missing function according to Stack Overflow: https://stackoverflow.com/a/40544743

    Regards,

    Zach

    Yeah, I noticed the minimum version of 5.5.0 for that curl_reset function too after I did a little digging myself. I installed 5.5.38 on my server and it is working just fine now- I was able to configure a calendar without any errors, and it is successfully pulling in events I added on my google calendar.

    Thanks again for all of your time and effort in this project. I am excited to use it on my website!

    Thanks so much for your help, and for your super fast response!: I just upgraded PHP on my site, and that solved the problem. I’m now at 5.5.13, which is currently the most recent version offered within my setup from a2hosting.

    I also get the following error when updating the plugin to this latest version:

    Update Failed: Internal Server Error

    I have PHP version 5.6

    Any ideas?

    I have PHP version 5.4.24 – I am not getting errors, but I am getting inoperable calendars on plugin version 3.1.11, and pages that don’t fully load as well as what looks like missing CSS. I have reverted to 3.1.10.

    Same problem here, running php 5.6:

    Fatal error: Call to undefined function GuzzleHttp\Handler\curl_reset() in /home/content/52/11138452/html/infoplantas/wp-content/plugins/google-calendar-events/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 78

    I have the same error. Imagine all the users who will never comment. This upgrade brought many sites down.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey all,

    We just released version 3.1.11.1 which should include a hotfix that prevents the site from going down if you’re running an older version of PHP. If you’re running PHP 5.5 or greater you should not run into the curl_reset() fatal error.

    Please update to the latest release and let me know if you continue to have errors. I will be monitoring these threads to help as much as possible with issues you may have.

    Regards,

    Zach

    Thank you for that. I’m on PHP 5.4.45 at the moment, but at least it tells me so nicely when the install fails. Rolling back to .10. This client is on Godaddy and the hosting package itself may not be able to upgrade the PHP version, depending on its age. I’ll find out.

    Plugin Author Zach Wills

    (@oxymoron)

    Hey @greg_r

    Thanks for the reply- I’m sorry again that you had to deal with the site crashing before. Please let me know if you run into any other issues.

    Regards,

    Zach

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Version 3.1.11 causes error’ is closed to new replies.