Support » Plugin: Post Snippets » Version 3.0.15 Problem Creating and Editing Snippets

  • Resolved fredb2020

    (@fredb2020)


    Updated and activated version 3.0.15 and tried to add snippets and change their names. This caused the plugin to act in very eradicate ways. Change the first snippets name save and exit. Come back and the last snippet name was changed and the first one was back to its previous name. Change any snippet name, save, exit, and return and the last snippet had the new name. Plus I could only add a new snippet by following a specific set of steps. Add new snippet, edit name, click the check mark beside the name, add the snippet body, and then save the snippet. Any other order of steps did not seem to save the snippet properly.

    I uninstalled and deleted the plugin, deleted the database record for it, reinstalled the plugin, and still had the exact same issue. The solution I found is to revert the plugin back to 3.0.14 and everything seemed to work as before.

    The site I updated to 3.0.15 is running WP 5.3.2 and PHP 7.3.

    We use this plugin on several sites and this problem makes the plugin unusable for us. We will have to stop updating this plugin until a fix is found.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same issue. Changing name on one of the snippets it changes always the name of the last one. I hope there is a bug-fix soon.

    checking the issue right now, let you know asap

    Please check version 3.0.16

    Thank you for fix – it works on my blog – everything is fine now.

    Other question: i miss the “save all” button. Can you bring this back in future versions or is it not possible because of the new structure of snippets?

    Well, I had to remove the “Save all” buttons because under some circumstances it couldn’t work (for example when trying to save hundreds of snippets and the website had a low value for the MAX post size).

    So while it worked for many users, for many other it didn’t and it’s also a kind of problem hard to detect (PHP throws an error before I can handle it) so I wouldn’t even be able to show a proper message. So I preferred to remove the button, sorry for this change :-\

    Thread Starter fredb2020

    (@fredb2020)

    Thank you for the quick response. Version 3.0.16 does fix the snippet editing problem we had.

    I still having the same issue.
    Post Snippets 3.0.16,
    WordPress 5.3.2,
    PHP 7.3.14,
    MySQL 5.7.27

    Also having the same issue. I cannot rename any snippets. They start off as “Untitled”

    Then no matter what I change them to, it goes back to “Untitled”

    • This reply was modified 11 months, 1 week ago by noslenwerd.
    Plugin Author WPExperts.io

    (@wpexpertsio)

    Hi @noslenwerd, @yskngc, @fredb2020, @greentreelabs, and @ralfreymann ,

    We are pleased to announce important news. Post snippets have been acquired by WP Experts. If being a user, you have any queries and issues, then we are solving your problems right here.

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Version 3.0.15 Problem Creating and Editing Snippets’ is closed to new replies.