Support » Plugin: Custom 404 Pro » Version 3.0.0. not working anymore

  • Resolved boleyn22

    (@boleyn22)


    After updating to version 3.0.0 the plugin does not work anymore. I don’t use the logging, just redirect to custom 404 but the changes are not saved anymore, no matter what I select. It always shows mode “None”. Please resolve that problem. Thanks!

    The page I need help with: [log in to see the link]

Viewing 12 replies - 16 through 27 (of 27 total)
  • All good, thanks for getting onto the fixes so quickly. Great plugin 🙂

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @dlwnz great, thanks! 🙂

    I tried Deactivate 2.1.3 > upgrade to 3.0.4 > Reactivate > and there is the end in that point. Plugin cannot be activated. Fatal error: Can’t use function return value in write context in /var/www/evaforever/data/www/skazka-veda.ru/wp-content/plugins/custom-404-pro/admin/AdminClass.php on line 221

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @elegance46 you need to deactivate the latest version (after upgrading) of the plugin and then activate it.

    I did it several times. The same error.

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @elegance46 okay I’ll look into it, have you tried re-installing the plugin?

    elegance46

    (@elegance46)

    Yes, sure I tried reinstall, but still the same mistake. Unfortunately I have to deactivate plugin and stop using it.

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @elegance46 not a problem, just want to check one more thing – is your PHP version less than 5.5? If yes, then this error will occur because of the way the code is written.

    I’ll try to make a fix for this in the next release. Meanwhile, if it’s possible for you, you can try a higher PHP version on a sandbox and see if the plugin works for you. Thanks for the bug report though! 🙂

    elegance46

    (@elegance46)

    Yes, my PHP Version 5.4.45-0
    I’ll try higher

    dlwnz

    (@dlwnz)

    Hi @kunalnagar

    A new small bug (for me) with this latest update from 3.0.5 to 3.1.1

    If you either upgrade without deactivating, or decactivate > upgrade > reactivate, the Mode (e.g. WordPress Page) stays as previously specified, but the ‘Select a Page’ setting gets bumped to ‘None (Default Error Page)’.

    Re-selecting my custom page and saving again fixes.

    P.S. I have various PHP versions across different sites but nothing below 5.6

    • This reply was modified 6 months ago by  dlwnz.
    Plugin Author Kunal Nagar

    (@kunalnagar)

    @dlwnz I see. Thanks for the bug report, I’ll take a look and release a fix 🙂

    Glowball

    (@glowball)

    My version said 3.1.1 but settings wouldn’t save. I deactivated the plugin, activated it again, and now it works again. Thanks!

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Version 3.0.0. not working anymore’ is closed to new replies.