Support » Plugin: Custom 404 Pro » Version 3.0.0. not working anymore

  • Resolved boleyn22

    (@boleyn22)


    After updating to version 3.0.0 the plugin does not work anymore. I don’t use the logging, just redirect to custom 404 but the changes are not saved anymore, no matter what I select. It always shows mode “None”. Please resolve that problem. Thanks!

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 27 total)
  • I am having exactly the same issue. Version 3.0.0 does not recognise my custom WordPress page that I have set, and won’t save when I try to re-specify it – just shows ‘None’. Any 404 request goes to theme or generic 404 page. Plugin was working perfectly up until 3.0.0 so have reverted to 2.1.3

    I realise the plugin author has said to use Github to report issues, but hopefully will take a peek in here anyway…

    • This reply was modified 6 months, 1 week ago by  dlwnz.
    • This reply was modified 6 months, 1 week ago by  dlwnz.
    Plugin Author Kunal Nagar

    (@kunalnagar)

    Guys. Sorry for the trouble, can you upgrade to 3.0.1 and try deactivating the plugin, activating it and updating the settings?

    We’ve moved to a new logging system taking into account other user feedback as well. All your old logs will still be there, I’m just working on a Migrate button that will bring all of them to the new system. Apologies for the inconvenience.

    On the other hand, if you are one of the people having the SEO issues and general dashboard slowness and don’t care about the previous logs, feel free to use the “Reset” tab.

    Hi Kunal, updated to 3.0.1, deactivated, activated again, tried to save new settings, but still the same problem as before. The settings just don’t save.

    Could you please provide a link to the old Version (2.1.3) for me to install until this problem is solved? Thanks!

    Plugin Author Kunal Nagar

    (@kunalnagar)

    Hmm. Try re-installing the plugin and then following the same procedure?

    If that doesn’t work, here’s the link to the old version: https://downloads.wordpress.org/plugin/custom-404-pro.2.1.3.zip

    This is even worse. I can’t delete the plugin and get an error message “deletion failed”. Should I even try now to reinstall the old Version? I don’t think so…

    Plugin Author Kunal Nagar

    (@kunalnagar)

    The “Deletion failed” error in WordPress is usually a permissions issue. Are you able to delete other plugins? There is no bug that I (or other users) have hit during deletion of the plugin, as of now.

    If it’s absolutely necessary, try FTP-ing into your site and deleting the custom-404-pro folder from the plugins directory manually and uploading the old one there.

    Thanks but I am the site admin. I deleted the plugin folder and installed another 404 Plugin which works just fine. Sorry!

    Hi Kunal,

    Tried upgrading, deactivating, activating and updating settings – issue still persists.

    Did a clean install of 3.0.2 on a sandbox site and still getting the same issue.

    Mode > WordPress Page > Page Selected > Save Changes > Changes ‘Save’ but Mode shows as ‘None’.

    I appreciate this is a free plugin 🙂 – thanks for your efforts in fixing this.

    David

    Plugin Author Kunal Nagar

    (@kunalnagar)

    I figured out the bug in the uninstall process thanks to both of you, it should now work in 3.0.4.

    @dlwnz could you please try the uninstall process one more time and let me know?

    @boleyn22 you wanna give 3.0.4 another shot?

    I really appreciate the testing. Thanks!

    • This reply was modified 6 months, 1 week ago by  Kunal Nagar.

    Ok – if updating from 2.1.3 to 3.0.4, for me the issue still persists. Mode shows as ‘None’ despite re-specifying the WP page for the 404.

    If uploading the plugin (for the first time) onto a clean site, it works fine, can specify a WP page for the 404, it saves and stays set.

    I haven’t tried to delete the plugin on a working site and re-install it, as I figure there will still be data in the DB?

    Edit: I deleted 2.1.3 off a working site. Uploaded 3.0.4, re-spec’ed WordPress page + my custom 404 page, saved it and it stays saved… and works on testing.

    So (for me) I can’t upgrade the plugin – I have to delete, upload and it works. I’m not concerned with the logs so much so this is ok.

    Thanks Kunal 🙂

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @dlwnz So if you upgrade from 2.1.3 to 3.0.4, you need to deactivate the plugin first, reactivate it and THEN update your settings.The reason for this is that the new logging model tables are only created on the activation hook, I should probably check and create them on the upgrade as well. Thanks, another use case fix!

    What’s the issue with the upgrade? I think if you try the above step, it should work.

    Also, I think going forward, the updates should be a lot smoother. Thanks again! 🙂

    Thanks Kunal, that works now for me with the following:
    Deactivate 2.1.3 > upgrade to 3.0.4 > Reactivate > Select Mode > Select Page > Save
    Thanks 🙂

    Plugin Author Kunal Nagar

    (@kunalnagar)

    @dlwnz great! Again, I appreciate the testing. Thanks. Let me know if you have any feedback on the logs side of things (i.e. if you decide to start using them) 🙂

    Thanks for your efforts, Kunal, but no thanks. I already spent too much time on this issue. Good luck!

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Version 3.0.0. not working anymore’ is closed to new replies.