WordPress.org

Support

Support » How-To and Troubleshooting » Version 2.9 image editor not working

Version 2.9 image editor not working

  • I just upgraded to 2.9 and am trying to crop an image before inserting it into the post but the new image editing is not working. When I pull up the option to edit the image, the button for cropping is by default somehow already selected, so I go ahead and drag my cursor to do the crop, which works, but then when I hit save, nothing happens. The “save” button appears to be inactive.

    The worst of it is that before I was using the plugin “scissors” to crop photos and it worked fine. I tried to reinstall that plugin to use it, but the new wordpress image editor overrides it and it is not showing up.

    My site is image heavy and I need to crop. Please help.

    Thanks.

Viewing 15 replies - 16 through 30 (of 43 total)
  • I experienced the same problem with crop tool on my local machine (using WAMP).
    I have Virtualhosts setup there. Just have noticed that if I change virtualhost root directory settings from “AllowOverride FileInfo Options” to “AllowOverride all” everything works fine.
    Hope this will help you.

    When opening my image editor at 2.9.1 it looks like this,
    http://i50.tinypic.com/s5ifbp.jpg
    But I can’t find the option where to rotate/flip the pic?
    Any ideas?

    @nedrwld: we’re on our own box, and allowoveride is set to all on all directories. no help there. but thanks for the suggestion.

    @rainer23: go to edit image and click the edit button. let us know here if your edited images insert or not.

    When I click the edit button nothing happens. When I adjust the Alignment and description and click “update” this is done.

    READ THIS:
    Chances are it might be your BROWSER. I was having the same issue in Firefox, tried it in IE 8 and it worked. I had to disable the screencapture ass-on. You may have a FF or IE add-on/toolbar that is causing problems. Try disabling all add-ons and see if it works.

    @taylhis thanks for the tip! unfortunately, disabling all add ons did not help. problem persists in firefox and safari.

    @harryjerry Thanks for directing us to this tutorial which gave me the solution on cropping my images in 2.9

    How To Crop Images in WordPress 2.9 Image Editor

    I had the same problem, until I realized that if I insert one of the smaller sizes (ie, thumbnail, small, medium, large, not full size), WP correctly inserts the edited image.

    It seems like the image editing functions are really half baked, for example: if i resize the image, the link url in the insert dialog still reflects the original image, and the dimensions in the sizes row is not updated with the new size until we refresh the dialog.

    edit: Oops, I apologize – I was using WordPress Mu and it seems that regular wordpress is working correctly.

    @recoilfx That’s OK! I am also having the image editor problems in WPMU 2.9.1 and just confirmed it is working on our standard WP install. I only chimed in here to see if any of these tips help, but they do not.

    I can confirm, however, similar symptoms as what you describe under WPMU — images inserted at full size (or thumbnail), only get stretched (if scaled) with no cropping effects. All effects apply correctly on images inserted at Medium size.

    Time to update that WPMU forums Image Editor topic!

    Same here… The Cropping tool just doesn’t work same with all the other buttons..

    So did anyone came up with a Solution yet?

    I am having a similar, yet WORSE problem. In one of my installations I can not get the image uploader to even open. When you click on the button, nothing happens.

    I only have 2 plugins and a few jQuery scripts in my theme. I deactivated all plugins & switched to the default theme, and it still DIDN’T work. I also re-uploaded the JS folder in hopes that the error was there…but to no avail.

    Is anyone else using .htaccess to direct a public_html folder/the site root to a wordpress install? I’m wondering if that has something to do with it.

    I can crop, but only when the selected area has dimensions equal or above 100px x 105px ! If the selected area has less width or height, the crop button gets disabled. Anyone can explain why? Or how to avoid this behavior?

    i seems to me that the crop tool button is disabled unless you select an area that is equal or above the thumbnail size you set in settings->media library… makes sense imo.

    I had a similar issue with firefox. What worked for me was either disabling the iSmooth firefox skin and/or upgrading to FF 3.6 I did both at the same time so I’m not sure which method worked.

    Well, I can no longer replicate the issue after upgrading to Firefox 3.6 using WP 2.9.1 … I didn’t/don’t have a custom browser skin, so the FF update must have done the trick. Thanks JohnathanNYC! (Haven’t yet tested on WPMU.)

Viewing 15 replies - 16 through 30 (of 43 total)
  • The topic ‘Version 2.9 image editor not working’ is closed to new replies.
Skip to toolbar