WordPress.org

Support

Support » How-To and Troubleshooting » Version 2.9 image editor not working

Version 2.9 image editor not working

  • I just upgraded to 2.9 and am trying to crop an image before inserting it into the post but the new image editing is not working. When I pull up the option to edit the image, the button for cropping is by default somehow already selected, so I go ahead and drag my cursor to do the crop, which works, but then when I hit save, nothing happens. The “save” button appears to be inactive.

    The worst of it is that before I was using the plugin “scissors” to crop photos and it worked fine. I tried to reinstall that plugin to use it, but the new wordpress image editor overrides it and it is not showing up.

    My site is image heavy and I need to crop. Please help.

    Thanks.

Viewing 15 replies - 1 through 15 (of 43 total)
  • Same for me, crop is not working for me and i have no idea why… I select area to crop, hit save and nothing happens…

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    The image editing is working fine in my 2.9 installs.

    I was using scissors, but it no longer appears with 2.9. So I deactivated it, and then reactivated it. This helped somewhat. I can either scale an image or crop it, but not both. I am on a Mac and have tried both Firefox and Safari. I’m thinking of downgrading back to the eariler version of WP because this is a pain.

    I can confirm the same problem. Rotate/flip all seem to work fine, but crop just doesn’t do anything apart from highlight a rectangle of the image. I’ve never used any image-editing plugins before.

    Two installs, same on both.

    I went through the same problem initially. Here’s a solution to the image crop problem you’re all facing (it’s not a problem btw, you’ll know)

    How To Crop Images in WordPress 2.9 Image Editor

    Alternately click here.

    Thank you for your article Harry. But there is another set of steps involved if you want to both crop and scale an image. My original image is 240 x 280 and I want to post an image frame that is 140 x 140. So first I need to crop it to a 1:1 aspect ratio. That leaves me with a 240 x 240 image. I must first save that cropped image and also click update media. Now, only after I have fully saved the cropped image, can i then go back to it and edit by scaling to 140 x 140. And hit scale – then save- and then update media.

    Crop first, save, then scale and save. You must do it in that order.

    If you ask me, this is a real problem bug, not a “silly” misunderstanding of how it works. This should be fixed so that you can crop and scale in the same sequence of steps.

    Thanks HarryJerry!!
    BergyOnWPI hear you. I was using scissors too, and it was working fine. Now 2.9 gives us an image cropping tool that prevents us from using scissors but isn’t as good as scissors. I applaud WP for putting in an image editing tool, but I’m surprisd/confused to see it not as good and as simple as a plug-in that we were all using. I hope this is fixed soon.

    Crop button appears disabled to me. I have tried disabling all plugins and crop button is still disabled (greyed-out). As others I used scissors before and all operations worked like a charm with it.

    Actually it was caused by some stray newlines in my functions.php. Now it works (but it would be cool to have the miniatures recreated after cropping).

    I was struggling with this for a bit, too. To get the cropping to work, you have to drag the window (hold SHIFT to lock the aspect ratio) and then click the crop icon (the one in the upperleft corner of the toolbar) to actually get it to crop.

    So, that works and appears the right way in the Media Library. Unfortunately, the post thumbnail stays the way it was when I first uploaded.

    @sinc Do you know exactly what in Functions.php was causing it? I deleted everything it mine to test it out, and it fixed the problem.

    The only issue is, I need everything in my functions.php file. If I delete it, my site doesn’t work. If I keep it, cropping doesn’t work. Help!

    I’ve been having issues with the crop tool as well. Except I don’t even have the ability to click on the image and highlight a section to crop.

    I have WordPress 2.9 running on two almost identical servers. Both IIS 6, PHP 5.2.6 (with bundled gd library enabled). The crop tool works on one server but not the other, and for the life of me I can’t find any difference between the servers other than the fact that one has gzip compression enabled and the other doesn’t.

    Also, I have tried deactivating all of my plugins and using the default theme.

    I experienced the same problem, and it appears that the culprit in my case was a widget — Collapsable Archives Widget, I believe. I deactivated it and the image editor seems to be working now.

    I am able to use the editor, and the changes update and preview properly, but the edited image does not get saved. The edited version appears in the library, but when inserted into a post the original image is displayed. Any feedback is greatly appreciated.

    Update:
    PHP version: 5.2.11
    GD Version: bundled (2.0.34 compatible)

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Version 2.9 image editor not working’ is closed to new replies.