Support » Plugin: Tag Manager - Header, Body And Footer » Version 2.3.0 causes PHP Fatal Error on multisite

  • Cameron Barrett

    (@cameronbarrett)


    Updating to the latest version of this plugin creates a PHP Fatal Error on every multisite when activated at the Network Plugin level.

    Rolling back to version 2.1.0 resolves this.

    Please fix this bug.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author yydevelopment

    (@yydevelopment)

    Hey sorry for the troubles,
    Are you able to share the error you are getting? I mean copy and paste the error you are getting.

    I have tried checking all variations of the plugin and i am unable to get an error so i need you to share the error and also let me know if you do something when it happen (like changing the tags code) or is automatically happen on update?

    Also, if you have access to the admin page see if this option is selected and if it’s selected try to unselect it and see if that helps.

    “Check this if your theme supports wp_body_open action (make the way the body tag getting loaded faster)”

    Thanks

    Thread Starter Cameron Barrett

    (@cameronbarrett)

    This is still happening when I upgrade to 2.3.0

    Fatal error: Uncaught Error: Call to undefined function wp_get_current_user() in /var/www/southsideisd.org/htdocs/wp-includes/capabilities.php:692 Stack trace: #0 /var/www/southsideisd.org/htdocs/wp-admin/network/settings.php(16): current_user_can() #1 /var/www/southsideisd.org/htdocs/wp-content/plugins/tag-manager-header-body-footer/include/install.php(11): include('/var/www/souths...') #2 /var/www/southsideisd.org/htdocs/wp-content/plugins/tag-manager-header-body-footer/index.php(40): require_once('/var/www/souths...') #3 /var/www/southsideisd.org/htdocs/wp-settings.php(339): include_once('/var/www/souths...') #4 /var/www/southsideisd.org/wp-config.php(125): require_once('/var/www/souths...') #5 /var/www/southsideisd.org/htdocs/wp-load.php(42): require_once('/var/www/souths...') #6 /var/www/southsideisd.org/htdocs/wp-admin/admin.php(34): require_once('/var/www/souths...') #7 /var/www/southsideisd.org/htdocs/wp-admin/network/admin.php(13): require_once('/var/www/souths...') #8 /var/www/southsideisd.org/htdocs/wp-admin/ne in /var/www/southsideisd.org/htdocs/wp-includes/capabilities.php on line 692

    Rolling back to previous version fixes this.

    Plugin Author yydevelopment

    (@yydevelopment)

    Hey I am still unable to recreate your error so i am not sure but i have tried to create a fix for that on version 2.3.1.

    Try to update the plugin for the new version and please let me know if that fixed the problem?

    Thread Starter Cameron Barrett

    (@cameronbarrett)

    Thanks, I can’t test this update today but will do a test with 2.3.1 later this evening.

    The client is only using this plugin to inject Google Tag Manager code, so I’ve instructed them to move that to Google Site Kit, but I will work with you to try to resolve this error.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.