Support » Plugin: Code Snippets » Version 2.10.1 crashes site’s backend!

  • Resolved talgalili

    (@talgalili)


    Just upgraded to Version 2.10.1 and I got 500 errors when trying to login into my wp-admin.

Viewing 15 replies - 1 through 15 (of 29 total)
  • After changing the dir name, and trying to re-activate, I get the following error:

    `
    Warning: require_once(/home/rstatis/public_html/wp-content/plugins/code-snippets/php/import-export.php): failed to open stream: No such file or directory in /home/rstatis/public_html/wp-content/plugins/code-snippets/php/class-code-snippets.php on line 60

    `

    Joe

    (@joewa1980)

    It’s because the file it’s calling (import-export.php) on line 60 of class-code-snippets.php does not exist. We’ve commented out line 60 and it works until the next update.

    So it won’t work until the next update?

    • This reply was modified 1 year, 5 months ago by  pedrofilho.
    Joe

    (@joewa1980)

    It will if you comment out the file it’s looking for that does not exist as per my instructions here: https://wordpress.org/support/topic/version-2-10-1-crashes-sites-backend/#post-9959903

    How can I “comment out” that file? I also have that same problem.

    Okey, I got it.

    Just replace line 60:
    require_once $includes_path . '/import-export.php';

    for that:
    /* require_once $includes_path . '/import-export.php'; */

    in file:

    wp-content/plugins/code-snippets/php/class-code-snippets.php

    • This reply was modified 1 year, 5 months ago by  kibus90.
    • This reply was modified 1 year, 5 months ago by  kibus90.

    Thanks Joe. Frontend and dashboard went white on me.

    same here on localhost php 7.2

    Commenting out line 60 solved this for now.

    Warning: require_once(C:\xampp\htdocs\wp.dev\wp-content\plugins\code-snippets\php/import-export.php): failed to open stream: No such file or directory in C:\xampp\htdocs\wp.dev\wp-content\plugins\code-snippets\php\class-code-snippets.php on line 60

    Fatal error: require_once(): Failed opening required ‘C:\xampp\htdocs\wp.dev\wp-content\plugins\code-snippets\php/import-export.php’ (include_path=’C:\xampp\php\PEAR’) in C:\xampp\htdocs\wp.dev\wp-content\plugins\code-snippets\php\class-code-snippets.php on line 60

    We manage a lot of sites and had Code Snippets set as a Trusted Update in MainWP. It took down 8 sites today.
    Downloading the previous version from the repo and FTP’ing it into the sites had all sites back in a few minutes.
    Download v2.9.6 here:
    https://wordpress.org/plugins/code-snippets/advanced/

    Neither editing line 60 nor downgrading to v2.9.6 work for me. Both show a 500 error if the plugin folder is in the directory. Only taking it out returns the site. What can I do?

    Took down my entire site this morning. Not cool.

    Thanks for the suggestion of the line edit. Very sloppy on the author’s part leaving out a required part.

    Had to clear OPcache and it is back again

    Thanks @kibus90. You saved my day!

    • This reply was modified 1 year, 5 months ago by  taxumi.

    I use ManageWP and updated about 10 sites and the new code snippets version crashed them all. I had to FTP in and change the name of code snippets folder and all sites came back to life.

    Thank you @kibus90. You saved me lots of time researching!

    Not nice this bug..

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Version 2.10.1 crashes site’s backend!’ is closed to new replies.