Support » Plugin: Simple Taxonomy Ordering » Version 2.0 throws a Fatal PHP Error on PHP 5.6.40.

  • Resolved rubenahlhaus

    (@rubenahlhaus)


    Hey,

    Since updating to version 2.0 the plugin throws a Fatal PHP Error.
    The error is caused by a function declaration name equalling an already defined function.

    yikes-custom-taxonomy-order.php has a function called include which breaks everything since include is already a defined function.

    I’m running WordPress 5.1.1 and PHP 5.6.40.

    This doesn’t happen when using PHP 7.1.8. I think the function should still be renamed as it’s a bad idea to declare a function using a built in functions name. I’m surprised it works at all in 7.1.8 to be honest.

    Reverting to version 1.2.7 has fixed the issue for now.

Viewing 1 replies (of 1 total)
  • Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hi @rubenahlhaus,

    We’re aware of this issue and will be pushing a fix either today or tomorrow. It only affects users on PHP versions < 7.0.

    Apologies for the issue.

    All the best,
    Kevin.

Viewing 1 replies (of 1 total)
  • The topic ‘Version 2.0 throws a Fatal PHP Error on PHP 5.6.40.’ is closed to new replies.