Support » Plugin: Simply Static » Version 2.0.0 Doesn’t Work For Me

  • Version 1.8 was working perfectly for me, and I LOVED it.

    So I upgraded to 2.0.0 with some trepidation.

    Doesn’t work. I sent the debug file.

    Please, please please could you make version 1.8 available again somehow. I am willing to pay.

    Thanks
    Mike

Viewing 14 replies - 1 through 14 (of 14 total)
  • Calm is restored.

    How to go back to version 1.8

    Download it from:
    https://github.com/codeofconductco/simply-static/releases

    Copy all your settings from the current version.

    Deactivate and delete the version 2.

    Copy and extract 1.8 to your wp-content/plugins

    Re-activate 1.8 – update your settings

    Should work again!

    I wish there was an easy way to roll back from a new plugin to a previous version to avoid this sort of situation.

    Or… test it as a different plugin name (and different database table) to test if it works first before you upgrade.

    Like try out SimplyStatic2Beta before upgrading.

    I’d be happy to be a beta tester.

    Cheers
    Mike

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    I’ll be working on fixing this shortly. I did test this across a variety of different sites, WordPress versions, and PHP versions and didn’t run into any issues.

    As far as I can tell based on the logs that folks are sending in, Simply Static is picking up on errors in other plugins and themes and halting when it encounters them. It seems like I made Simply Static a little too good at catching errors.

    I’ll work on rolling back that aspect of it.

    Best
    Scott

    P.S. Thanks for your offer to be a beta tester! I may well take you up on that.

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    Can you try out v2.0.1 of Simply Static? I believe I’ve got that issue fixed.

    Best,
    Scott

    Hi Scott,

    Tried version 2.0.1 and it works 🙂

    Thanks for sorting.

    Assuming it might have been an error with my theme, which I wrote myself, could you give any clues as it would be good to fix them. The theme seems to work fine otherwise.

    Cheers
    Mike

    It’s stopped working again.

    Getting lots of 403 errors…

    In the debug file it says it’s trying to save to /tmp/ folder rather than the one designated in the settings.

    I’ve tried resaving this but to no avail.

    I’ve tried generating the static site about 15 times now in an attempt to find a pattern of why it’s not working, it worked twice during that time. But I couldn’t see any pattern.

    I’ve forwarded three debug files (for learningtodraw.online ) the last one was when it actually worked.

    Anyone else get this working yet?

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    Thanks for sending in those debug logs. I’ll take a look.

    Best,
    Scott

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    I’ve been taking a look into this. One thing I’ve noticed is that you’ve blocked public access to http://learningtodraw.online/mountaineeroftheyear2016. That’s fine, but my guess is that depending on how Simply Static is fetching content from your site it either falls in or out of the rules for being blocked. Could you share those rules with me? (Probably in an .htaccess file?) My email is: scott@codeofconduct.co

    That should help me replicate the issue, and then I can either figure out if I can fix it on Simply Static’s side or advise folks on how to adjust their rules so that they don’t get the 403 errors that you’re seeing.

    Best,
    Scott

    Hi Scott,

    Yes I’ve restricted access to my home IP and the server IP address. 1.8 worked with these restrictions.

    When I was testing with 2.0.1 I unrestricted that directory but it didn’t help.

    I’ll double check now….

    OK, it worked fine 3 times in a row when I unrestricted that folder this time. Hmm maybe I only thought I’d unrestricted it before…

    When I re-restricted it it failed again, have forwarded the debug log.

    It would be good if it would work with those restrictions that would be good. 1.8 did. I would have thought it should as I’m allowing access from itself?

    Cheers
    Mike

    PS. can you edit your previous post so it doesn’t reveal my secret folder… or maybe I’ll just change it’s name now!

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    Sorry, I can’t edit that post anymore. My apologies.

    Anyway, I’ll take a look at adding something to diagnostics on where the requests originate from to make it easier to whitelist ip addresses.

    Best,
    Scott

    Hi Scott,

    OK, thanks, that should help.

    Cheers
    Mike

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi Mike,

    I’ve just released v2.0.2 of Simply Static, which includes a new item on the Diagnostics page for checking if WordPress is able to access itself. Is that check returning a green response?

    Best,
    Scott

    Hi Scott,

    Thanks for those.

    So the first things I noticed was that there was a FAIL for:
    “Checking if web server can read/write from Temp Files Directory: ”

    I made the temp folder 777 (it was 744) That seemed to rectify that in the diagnostics.

    So with my .htaccess still restricting access for my non-static site to itself and my home IP, I ran SS.

    It failed 🙁 (Sent debug.txt no. 1)

    Then I noticed in diagnostics

    “Checking if WordPress can make requests to itself from XXX 301”

    Which was 301 so OK but that IP address wasn’t set to allow in my .htaccess so I added that for good measure.

    Ran second time, failed again 🙁 (Sent debug.txt no. 2)

    So in .htaccess I lifted all restrictions.

    Ran third time, failed again 🙁 to my surprise! (Sent debug.txt no. 3)

    So tried again for a second time without restrictions and it worked cleanly this time 🙂

    So not sure if that is any help, I hope so.

    So at the moment 1.8 still looking like best option for me as that seems to work with .htaccess restrictions on the non static site.

    You can email me directly on mike at learningtodraw.online if you don’t want to clutter the forum with debug stuff. Happy to do further testing.

    Cheers
    Mike

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Version 2.0.0 Doesn’t Work For Me’ is closed to new replies.