WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Version 1.5.5 is giving warning message – should I be worried?

[Resolved] Version 1.5.5 is giving warning message – should I be worried?

  • Hi Baden

    Just installed Collapse-O-Matic version 1.5.5. Everything seems to work fine. But now in Admin, I’m getting the following message at the top of each page:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘WP_Collapse_O_Matic’ does not have a method ‘admin_init’ in /home2/nickwing/public_html/test8/wp-includes/plugin.php on line 429

    Should I be concerned by this message?

    NB. Regarding the file it refers to: wp-includes/plugin.php. I’ve downloaded a virgin copy of WordPress 3.71 and compared its plugin.php to mine. They are identical.

    Cheers

    Nick

    http://wordpress.org/plugins/jquery-collapse-o-matic/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Hi I am getting the same error after upgrade:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, class ‘WP_Collapse_O_Matic’ does not have a method ‘admin_init’ in /home/gfesport/public_html/wp-includes/plugin.php on line 429

    Also getting this:

    Warning: Cannot modify header information – headers already sent by (output started at /home/gfesport/public_html/wp-includes/plugin.php:429) in /home/gfesport/public_html/wp-includes/pluggable.php on line 899

    me too:
    ‘Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘WP_Collapse_O_Matic::admin_init’ was given in /home/elatedco/public_html/wp-includes/plugin.php on line 429′

    I’ve disabled it, but need it back please!

    Plugin Author Baden

    @baden03

    Issue is fixed with 1.5.6
    We also fired the drunken pirate monkey that is suppose to test code before it’s published.

    Thanks for your Support, Baden. You earned an upgrade. I’m going Pro…. Hi Five!

    Much obliged Baden

    Great service -as ever!

    Plugin Author Baden

    @baden03

    very happy it worked out!
    don’t forget to vote for pedro!

    Hi Baden.

    Thanks for getting back to us so quickly. I just activated and unfortunately still getting an error

    ‘Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, ‘WP_Collapse_O_Matic::admin_init’ was given in /home/elatedco/public_html/wp-includes/plugin.php on line 429′

    Thanks!
    Karen

    oops, forgot to update it. Duh I feel like an idiot now!

    Thanks!

    I have the Version 1.5.6 end stil have the eror… http://www.bisericadunamis.ro/
    I disabled the plugin for a moment, as the error remains … I’m confusing.

    Plugin Author Baden

    @baden03

    Bucur,

    Please completely de-install the plugin and re-install it from the wordpress repo. If that dose not solve the issue, let us know and we’ll take a closer peek.

    Plugin Author Baden

    @baden03

    if that does not work for you, then please try updating to version 1.5.7a direct from the plugin oven: http://plugins.twinpictures.de/plugins/collapse-o-matic/

    1.5.7.a no reaction for me. Looks like I ruined churches website. If I’d not update plugin… I’am not a expert php. What am I doing now?

    Plugin Author Baden

    @baden03

    Bucur: Send an email to: info [at] twinpictures [dot] de and we’ll get you squared away. There must me a simple reason why things are not working… and we want you to get back up and running soon as possible.

    Problem solved, the error code was in header.php.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Version 1.5.5 is giving warning message – should I be worried?’ is closed to new replies.