Support » Plugin: Yoast SEO » Version 14.0.1 Breaks Featured Image When Posting to Facebook

  • Resolved supertrooper2

    (@supertrooper2)


    Version 14.0.1 breaks the featured image when a post shared to Facebook. It does not show the featured image saved on the WordPress post but sends the fist image in the post, which is diferent to the featured image. When checking this issue on the Facebook Debugger the following error message is observed:

    Provided og:image URL, https://xxx.com/wp-content/uploads/2019/11/shutterstock_xxx.jpg could not be processed as an image because it has an invalid content type.

    To resolve this issue Version 14.0.1 has been removed and replaced by Version 13.5. Sharing to Facebook now works properly again by using the featured image embeeded in the post.

    When is this issue going to be resolved?

Viewing 10 replies - 1 through 10 (of 10 total)
  • net

    (@krstarica)

    I confirm the issue, this is a serious one.

    Yes I am having a similar issue. It fetches the featured image but not the description or the title.

    When shared on Telegram it does not show the thumbnail in full-size either

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @supertrooper2,

    We’ve released a few patch releases and the current version is 14.0.4, can you please update to this version and check whether this issue persists?

    Thread Starter supertrooper2

    (@supertrooper2)

    Hi Jeroen, I have checked the latest version 14.0.4 but the issue still persists!

    I have had to revert to Version 13.5 to resolve the issue.

    Hoping you will be able to resolve this issue.

    Plugin Support devnihil

    (@devnihil)

    @supertrooper2 We’re sorry to hear that the issue is still affecting you even after updating to the 14.0.4 patch release. Based on the information you provided, we expect this to be a bug. We’re actively using the bug tracking on our GitHub repository so your best next step would be to create a new issue for our developers at https://github.com/Yoast/wordpress-seo/issues/new. You will need an account to create a new issue. If this is your first bug report, please check out: https://kb.yoast.com/kb/how-to-write-a-good-bug-report/.

    Don’t forget to include the URL to this conversation in your bug report.

    Thread Starter supertrooper2

    (@supertrooper2)

    New issue created in GitHub:

    Version 14.0.1 Breaks Featured Image When Posting to Facebook #15049

    Hope you can resolve this critical issue.

    Plugin Support Michael Tina

    (@mikes41720)

    The GitHub issue pertaining to this has already been closed, setting this to resolved as well.

    Thread Starter supertrooper2

    (@supertrooper2)

    The situation with our website is a special one because we mainly use external image URL’s in conjunction with the plugin FIFU (Featured Image from URL).

    We discovered that SEO Yoast was having a problem with external image URL’s. So we worked with the FIFU developers and they came up with a solution to this issue:

    Version 14.0.4 is now working perfectly again.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hey @supertrooper2,

    Thanks for letting us know!

    Have a great day.

    net

    (@krstarica)

    We are not using external images and yet have this issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Version 14.0.1 Breaks Featured Image When Posting to Facebook’ is closed to new replies.