Support » Plugin: ImageMapper » Version 1.2.4: Embedded Map in Page Template

  • Resolved kmg1016

    (@kmg1016)


    Hi, I just updated the software from 1.2.3 to 1.2.4, and the map I had embedded in the page template is no longer displaying. I have reverted to an older version of ImageMapper (1.2.2) to get the map to display properly. Assistance resolving the issue would be much appreciated.

    This is the code I’m using within the PHP template to embed the map:

    <div id=”home-map”>
    <?php echo get_imgmap_frontend_image(‘15617’, ‘79467984’); ?>
    </div>

    Thanks,
    Kevin

    https://wordpress.org/plugins/imagemapper/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same problem here.
    The “src” attribute of the img tag is empty on 1.2.3 and on 1.2.4.

    Any solution?

    Thanks

    Any answers on this? Never received a reply…

    Still bugged for me too, which prevents me to update either the WordPress core and the plugin.

    Hi, i’ve solved this bug by editing the file imagemapper.php on line 391.

    Replace
    $id = $atts['id'];

    For
    $id = $atts;

    Since $atts is not an array and the function only uses the id that gets passed to the function this will solve the issue.

    @boozter :
    if you do that it corrects the problem of the direct call of the function but you break the use of the shortcode : [imagemap id=”xxx”]
    $atts is an array if you come through the shortcode, and an integer if you call the function directly.
    So i changed your code to adapt to the polymorphism of the $atts var:

    line 391 becomes :
    if (is_array($atts)) {
    $id = $atts[‘id’];
    } else {
    $id = $atts;
    }

    And it’s working in both cases

    I really don’t understand why the dev team just ignore this topic and release (again) a new version which break the use of the shortcode.

    I found a good solution. I used the old version of the map software, viewed the source code of the page (with the map in it), copied the code (image + image map) and used it instead of the reference to the plugin. Essentially, this just turns the plugin into a standalone map editor that doesn’t really function properly within WordPress.

    did you try with the new version? 1.2.5

    Just read the code of the new version and saw that the incriminated line wasn’t changed, so I guess updating the plugin will again break my site

    Hi,

    I posted my reply previously on an already resolved ticket, so maybe it was missed.. sorry for re-posing it, but I think it will resolve this issue.

    Regarding 1.2.4 – The new fix/version is ignoring users who call “get_imgmap_frontend_image” directly from the theme.

    For backward compatibility, it’s better to create a new function to put into add_shortcode, and make “get_imgmap_frontend_image” call that function.

    Also, new code ignores the element id that was passed as parameter, that can break CSS rules that were based on that name.

    Fix for the above 2 issues is here: http://pastebin.com/3Um1HKtF

    If you have the solution, just send it to tarmo@iki.fi

    There is a link to the fix in my message + full explanation about the cause of the issue.

    Fix available here: http://pastebin.com/3Um1HKtF (based on 1.2.4)

    Plugin Author Tarmo Toikkanen

    (@tatti)

    Thanks, edanwp! I’ve updated the plugin with the changes you proposed. Hopefully the issue is now solved.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Version 1.2.4: Embedded Map in Page Template’ is closed to new replies.