Support » Plugin: Styles » Version 1.1.1 appears as version 1.0.5 & still no Google fonts

  • Resolved Rivanni

    (@rivanni)


    I downloaded and installed version 1.1.1 today. In the plugin manager is says it’s version 1.0.5. I don’t mind the version number but I still don’t see the Google fonts. Can you fix the download so I can get the real 1.1.1 version?

    http://wordpress.org/plugins/styles/

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author PD.CM

    (@pdclark)

    I’m seeing version 1.1.1 in Styles downloaded by the updater. However, I do see that Styles: TwentyThirteen is at version 1.0.5. Please make sure you’re updating the main Styles plugin, not Styles: TwentyThirteen.

    Screenshots:

    You’re right. I was looking at the wrong plugin. Sorry. The Styles plugin is indeed version 1.1.1.
    BUT, I still don’t see any Google fonts in the list. Let alone any font previews.

    Plugin Author PD.CM

    (@pdclark)

    You should see it in all of the text fields in the customizer. Here’s a screenshot.

    Do you see the menu there? If not, can you share a screenshot of what you do see?

    https://www.dropbox.com/s/iv1yf7uuazmboq3/fonts.png
    Palatino is the Google font I set using a previous version of Styles.

    [Moderator Note: Please ensure that you are embedding links correctly in your posts.]

    Plugin Author PD.CM

    (@pdclark)

    I see. That’s not correct. It looks like the browser you’re using isn’t accepting the preview styling. Can you tell me what browser and version you’re running so I can try to duplicate the issue?

    I was using Chrome.
    Here is a screenshot from Firefox, where the previews of the standard fonts are shown.

    And here the one from Opera. No previews but, like in Firefox, a more condensed list than in Chrome.

    PS. I doubt if Palatino is a Google font. Another font I used on my site doesn’t appear in the list. Not even by name. And I know for sure that that’s a Google webfont.

    Plugin Author PD.CM

    (@pdclark)

    Can you name the font? Palatino isn’t a Google font — it’s a standard webfont installed on most computers (and it sets up a font stack in case it’s not).

    All the Google Fonts are listed further down. They’re pulled directly from Google’s API, but filter out non-latin fonts.

    I forgot to mention the version numbers. Here they are:
    Chrome v31.0.1650.48
    Firefox v25.0
    Opera v12.16
    Opera v17, (shows the list the same as Chrome; both webkit engine)
    IE v11.0 (shows the list the same as Firefox.)

    The Google font I used is Dancing Script.

    Plugin Author PD.CM

    (@pdclark)

    Hi Rivanni,

    We’ve tested on 3 Windows computers in Chrome, Firefox, and IE, and everything appears to be showing up okay from the plugin. These steps might help resolve the issue for you:

    * Clear your browser cache (hold shift and click refresh in the browser)
    * Try deleting and reinstalling the plugin. Don’t delete it through the WordPress admin — that will remove your settings too! Instead, delete the plugin directory over FTP, then re-upload it by downloading it from wordpress.org, extracting the .zip, and copying the files to your server.

    I did all those things yesterday and even tried them again just now. But the problem remains. I also tested in a virtual machine (clean install of Windows and browsers).
    I’m using WordPress 3.7.1 by the way.

    Plugin Author PD.CM

    (@pdclark)

    What version of Windows? Are you getting any 404’s if you look in Chrome > Developer Tools > Network? (There might be a permissions issue keeping some file from loading.)

    Plugin Author PD.CM

    (@pdclark)

    Or, would it be possible to get a temporary admin login to your site? (Emailed to styles@stylesplugin.com)

    Windows 8.1 Pro. But I’ve the problem too on Windows 7 Ultimate. All up to date. I don’t think it’s a Windows or browser problem.

    I do get 404 errors when clicking on the Customize button.

    Plugin Author PD.CM

    (@pdclark)

    Thanks very much. I see the error and that it’s an incompatibility with IIS. I’ll work on getting a fix released.

    Plugin Author PD.CM

    (@pdclark)

    This should be fixed in version 1.1.2 just released. Thank you for taking the time to work through this issue with me! I have credited you in the changelog.

    I tried updating the plugin for you to test that the fix worked, but it looks like the WordPress auto-updater doesn’t have permissions to delete the old plugin. You may have to upload it over FTP.

    Once you update, if that fixes your issue, please go ahead and delete the temporary user you created for me.

    If you find Styles useful, please share your thoughts in a short review!

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Version 1.1.1 appears as version 1.0.5 & still no Google fonts’ is closed to new replies.