Support » Plugin: LittleBot ACH for Stripe + Plaid » Version 1.2.8 broken site – Just tested

  • Hey Justin,

    My last support post was to clarify what’s in the latest update to 1.2.8 and I went ahead and tested the update. It completely breaks the ACH payment page. Working fine on 1.2.7 and now the page is just blank. Almost as though the short code isn’t being recognized. Not sure. I reverted back and restored my site from a few hours ago, working fine again… So 1.2.8 has issues

Viewing 10 replies - 16 through 25 (of 25 total)
  • Plugin Author justinwhall

    (@jwind)

    I’m really sorry that it conflicts with another plugin. I would suggest contacting the plugin that is including the SDK while not actively using it. I was contacted for not doing so and made the change to be compatible with a very popular plugin. I would expect that other plugins to do the same.

    https://wordpress.org/support/topic/breaking-conflict-with-gravity-forms-stripe-addon-v3-4/

    • This reply was modified 2 years, 2 months ago by justinwhall.
    Thread Starter crucible67

    (@crucible67)

    Ok, just opened a ticket with them and referred our conversations. Let you know what they say. Thanks

    I have a ticket open with WP Simple Pay.

    Disabled this one until this issue can be resolved.

    Of note, if this plugin gets cleaned up, I would have no issues paying for it.

    Plugin Author justinwhall

    (@jwind)

    So your plugin is ONLY useable on sites that don’t run other popular Stripe plugins?

    No. But if a plugin loads the SDK when they are not actively using it (they shouldn’t) then yes, the risk of conflict is there (this is not unique to this plugin).

    The user has to enter the amount. My clients don’t get to pick the amount, and, that leaves room to screw things up

    What exactly are you looking for? Are you wanting to attach payments to users(customers) and send a unique URL to them? Or are simply looking to create more than one form with fixed amounts?

    The former can be achieved with my invoice plugin + the ACH addon.

    Of note, if this plugin gets cleaned up, I would have no issues paying for it.

    In your words, what would that look like? I can’t address other plugins but I can make changes or perhaps make recommendations depending on what you are looking to achieve.

    I am using the same plugin WP Simple Pay. Has anyone gotten it to work with ACH yet? If so, can you please provide the solution? I’m tearing my hear out from the root! Any assistance would be greatly appreciated!

    Thanks!

    • This reply was modified 2 years, 1 month ago by wpNoob2012.

    I use 2 different pages… The main page talks about donation options (non-profit) and has WP Simple Pay on it. It also includes an option for ACH and goes to a separate page. I use Plugin Organizer to restrict each plugin from loading on the other page. So this plugin doesn’t load on the main page, and WP Simple Pay doesn’t load on the “debit” page.

    Thread Starter crucible67

    (@crucible67)

    @wpnoob2012 not yet. @geek2009 has interesting approach, maybe try that and let us know? I’m stuck with previous version until @jwind can find solution. WPSimplePay is popular plugin, so I suspect many users will run into this issue…

    Plugin Author justinwhall

    (@jwind)

    I do want to be clear here on a couple things:

    1) You only need to disable WPSimplePay on the page this plugin runs on. You _don’t_ need to disable this plugin on the WPsimplepay page as this plugin will not interfere with WPsimplepay.

    2) I am not looking for a solution. The issue is WPsimplepay includes the stripe SDK when not actively using it and I don’t have control over that.

    Right, but there is also no real reason to run both plugins on every page if it’s not necessary.

    Plugin Author justinwhall

    (@jwind)

    There’s also no harm assuming they don’t conflict.

Viewing 10 replies - 16 through 25 (of 25 total)
  • The topic ‘Version 1.2.8 broken site – Just tested’ is closed to new replies.