Support » Plugin: Health Check & Troubleshooting » Version 1.2.4 incorrect error message

  • Version 1.2.4 in Site Status tab shows incorrect error message ‘The required module, mcrypt, is not installer, or has been disabled.‘ My PHP version is 7.2.13. mcrypt module was deprecated in PHP 7.1, and removed in PHP 7.2.0. As a matter of fact this module was never required in PHP.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Marius L. J.

    (@clorith)

    Hiya Frank,

    Thank you for the heads up here, you are absolutely right, if you are running PHP 7.2 it should not show up as a required library, we’ll get that sorted out, thank you again 🙂

    You are correct that it was not a library required by PHP it self, but it is set as a “must have” by the WordPress hosting community, where the library recommendations come from, just to give an explanation for why we marked it as required.

    Thread Starter Frank P. Walentynowicz

    (@frankpw)

    Hi Marius,

    Thanks for your quick response.

    Plugin Author Marius L. J.

    (@clorith)

    Just letting you know that although proper information here would be nice, it wasn’t considered crucial to get fixed in 1.2.5, which focused purely on regressions the previous security update introduced.

    Just didn’t want to get your hopes up on an update that didn’t have this sorted, but it’s not been forgotten!

    Plugin Author Marius L. J.

    (@clorith)

    Hi,

    This has been put in and will be available from version 1.3.0 of the plugin 🙂

    When is the update due? PHP 7.3 and still have ” The required module, mcrypt, is not installer, or has been disabled.”

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Version 1.2.4 incorrect error message’ is closed to new replies.