• fuvavi

    (@fuvavi)


    This plugin use wp_die() detroy my site.

    • This topic was modified 8 months ago by fuvavi.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author apasionados

    (@apasionados)

    Hi @fuvavi,

    We are very sorry to hear that your site didn’t work after we released the v1.2.0 which was improving the plugin security. One of the points was to make absolutely sure that nobody that doesn’t have administrator privileges can access the plugin configuration.

    This check looks up if the user is an admin and if not it executes wp_die() to exit the plugin configuration. Unfortunately the behaviour on some sites was not as expected. This was fixed in version 1.2.1 after Mike Martin helped us to trace the problem as we couldn’t reproduce it on our test sites.

    We are developing these plugins trying to help the community and are very sorry if they cause problems. We are a small team and try to do our best.

    Best regards from Spain.

    Thread Starter fuvavi

    (@fuvavi)

    It took me 3 days to find out about this problem.
    I hope you will test carefully before publishing the plugin.

    Best regards.

    Plugin Author apasionados

    (@apasionados)

    Hi @fuvavi,

    We really try to do our best and didn’t have problems on our staging servers. Now that this security check is in place, the changes that are planned do not use functions like this one.

    Best regards from Spain.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Version 1.2.0 destroyed my site’ is closed to new replies.