Support » Plugin: WP Crontrol » Version 1.13.2 missing vendor subdirectory

  • Resolved integritive

    (@integritive)


    The most recent update is missing the wp-crontrol/vendor subdirectory. This generates a fatal error due to the require_once __DIR__ . '/vendor/autoload.php'; command in wp-crontrol.php:45

    • This topic was modified 1 month ago by integritive. Reason: Removing unnecessary passive-aggressive snark
Viewing 11 replies - 1 through 11 (of 11 total)
  • boardboss

    (@boardboss)

    There were two links to download the fix here: https://wordpress.org/support/topic/version-1-13-2-missing-vendor-subdirectory/

    Someone deleted that post.

    Micha

    (@michaing)

    Here is a fix until a new version has been released:

    
    cd /tmp
    curl -LO https://github.com/johnbillion/wp-crontrol/archive/refs/tags/1.13.2.tar.gz
    tar xf 1.13.2.tar.gz
    mv wp-crontrol-1.13.2/vendor /var/www/wordpress/wp-content/plugins/wp-crontrol/
    rm -R 1.13.2.tar.gz wp-crontrol-1.13.2
    

    Adjust the path to your WordPress accordingly, of course.

    boardboss

    (@boardboss)

    I confirmed that if you download the plugin from wordpress.org “right now”, the vendor folder is missing from that archive.

    boardboss

    (@boardboss)

    I will try and post the link and see what happens: https://github.com/johnbillion/wp-crontrol/releases/tag/1.13.2

    This file has the vendor folder in it. Upload only the vendor folder.

    kgagne

    (@kgagne)

    Upload only the vendor folder.

    I uploaded the whole folder, and my site came back up, with v1.13.2 of the plugin active.

    Thanks for the link to the download!

    boardboss

    (@boardboss)

    Glad I could help. I hope others read this thread and stop posting new ones. 🙂 Maybe the OP could mark it solved.

    Plugin Author John Blackbourn

    (@johnbillion)

    WordPress Core Developer

    Thanks for the reports everyone.

    I’ve released version 1.14 which reverts the changes made in 1.13. The issue is not with the plugin itself but with its deployment process to wordpress.org which misses the files in the vendor directory. I’m investigating the root cause and hopefully I’ll be able to re-release the new update again soon.

    Pt

    (@bncpeter)

    Thanks @johnbillion,
    can you please confirm if it is OK to use 1.14 from wordpress.org since it is also missing the Vendor directory? Was the Vendor directory new in version 1.13.x?

    Thanks for the quick action to resolve.
    Pt.

    boardboss

    (@boardboss)

    can you please confirm if it is OK to use 1.14 from wordpress.org since it is also missing the Vendor directory? Was the Vendor directory new in version 1.13.x?

    Two sites updated automatically overnight to 1.14. Both sites are running fine. I confirmed this morning that the download from wordpress.org does *not* contain a ‘vendor’ folder, and neither of my two sites has a ‘vendor’ folder. Maybe the ‘vendor’ folder is no longer needed, and the code was updated accordingly?

    Hi All,

    My WP Crontrol had automatically upgrade to version 1.13.2 and faced the problems “There has been a critical error on this website.”

    Is it any possibility for step by step to solve this problem.
    I had get through all of the information on the pages but still not sure how can I make it as my wordpress can’t login and the only way I can login is my A2 hosting pages.

    Pt

    (@bncpeter)

    @patrixquek
    If you have FTP or file access through your hosting:

    1. Delete the old/broken plugin version from /wp-content/plugins/wp-crontrol/. You could possibly also just rename the directory if you are worried about deleting it. This alone should fix your critical error, allowing you to login to WordPress and install the most recent version of WP Crontrol the usual way; WP Admin > Plugins > Add New.
    2. Alternatively, download the latest version of the plugin from wordpress.org then…
    • If using FTP, you will need to unzip it on your local machine and then upload it to /wp-content/plugins/wp-crontrol/.
    • If using a file manager via your hosting provider, you may be able to upload the zip and then extract it in place.

    It should be fine to delete the plugin directory and install a fresh copy. The plugin will store its settings in the database, which you won’t be touching.

    Hope that all makes sense?
    Pt.

    • This reply was modified 3 weeks, 1 day ago by Pt. Reason: typo
Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.