Support » Plugin: WP-Piwik » version 0.9.9.9 conflicts with wpmandrill

  • Resolved mhenschel

    (@mhenschel)


    Hi,
    just updated to the new version. This will result in a conflict with wpMandrill. This is the message that will be displayed:

    Mandrill: wp_mail has been declared by another process or plugin, so you won’t be able to use Mandrill until the problem is solved.

    Michael

    https://wordpress.org/plugins/wp-piwik/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author braekling

    (@braekling)

    Can you please try to comment line 38 of WP-Piwik?

    It shows following code:
    require_once(ABSPATH.'wp-includes/pluggable.php');

    And should look like this after commenting:
    //require_once(ABSPATH.'wp-includes/pluggable.php');

    I’m quite sure this will fix your issue. Later this day I check why I had to load these WordPress core file, and how I can avoid this.

    Plugin Author braekling

    (@braekling)

    Fixed in 0.9.9.10.

    If you can’t wait, just use the current development version:
    http://downloads.wordpress.org/plugin/wp-piwik.zip

    Thanks, I tried your fix above, which worked. My other sites stayed on 0.9.9.8 so far.

    Michael

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘version 0.9.9.9 conflicts with wpmandrill’ is closed to new replies.