WordPress.org

Support

Support » Plugins and Hacks » Google Maps Widget » [Resolved] Version 0.60: curl_init() Error for Lightbox Zoom Over 14

[Resolved] Version 0.60: curl_init() Error for Lightbox Zoom Over 14

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WebFactory

    @webfactory

    As the error says – you don’t have the CURL PHP module. It’s unfortunately required to use the plugin.

    Hmmm…
    I went straight to php.ini and enabled the CURL extension, and BAM! The map came to life. Thank you very much.
    Still I must ask this: How come this problem arose only at zoom over 14? Does it mean that the CURL extension is not required for lower zooms?

    Plugin Author WebFactory

    @webfactory

    Glad you got it working.
    Map locations for zoom levels of up to 14 can be defined via an address. For higher zoom levels it has to be done via lat/lng coordinates. Since users always enter only an address we have to convert it to coordinates via Google’s Geo API and hence the need for CURL. Yes, it’s as illogical as it sounds 🙂

    Thanks for the explanation.
    And thanks for a great plugin.
    Just suggesting: I’m sure it’ll come across much easier, if you could ‘catch’ the absence of this extension, then issue a more meaningful message when the selected zoom is over 14.
    I’m totally sure you have this on the to-do list!:)
    Again, thank you very much.

    Plugin Author WebFactory

    @webfactory

    You’re welcome! As soon as we switch to the new Maps API we’ll have that warning 🙂

    If you find the time, please rate the plugin. It helps us out a lot. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Version 0.60: curl_init() Error for Lightbox Zoom Over 14’ is closed to new replies.
Skip to toolbar