Support » Plugin: Shortcake (Shortcode UI) » Version 0.7.0 interferes with WooCommerce Products

  • Resolved AlexGoodall

    (@alexgoodall)


    I had problems this morning with the configuration panel of WooCommerce Products e.g. clicking on the links to change the tabs did nothing – and other oddities that made it impossible to edit Products.

    After considerable investigation, I found that the culprit is Shortcode UI 0.7.0.

    After restoring version 0.6.2, normality with WooCommerce Product configuration was achieved.

    Alex

Viewing 9 replies - 1 through 9 (of 9 total)
  • I can confirm that the plugin version .7 is incompatible with newest WooCommerce.
    Problem is JS errors on the edit product page which will restrict you from being able to change product options via the product option tabs.

    southaussienomad

    (@southaussienomad)

    This also happened to me and we traced it back to this plugin. Have de-activated version 0.7.0 and all ok now.

    Description of problem sounds like above.

    In the Product Data field where there is normally a drop down to choose:
    Simple Product
    and fields to choose
    Virtual/Downloadable
    Regular Price
    Sales Price
    all disappeared – can’t see them at all.

    Locked out of the Product Data section. Can’t navigate to Shipping or Variations or other options.

    At the same time, it appears the Yoast SEO has also lost a number of fields.

    Rok Balboa

    (@rok-balboa)

    I can also confirm, just yesterday, after installing Shortcake (Shortcode UI) Version 0.7.0, in Woocommerce couldn’t work with images. JS error os something.

    I have the same issue. Had to disable Shortcake

    • This reply was modified 10 months, 3 weeks ago by  PegWeb.

    Yes, this is a HUGE problem as it cannot be used with WooCommerce. It interferes with all its UI in the backend (WooCoomerce -> Settings)

    When can we see a fix? As i made the mistake of updating this plugin and now everything in woocommerce is all over the place. I will have to roll back.

    Im using this with ProfilePress and seems that ProfilePress does not work without this. So stupid to set dependencies on something that is badly coded.

    Alex

    Same problems. Incompatible with WooCommerce. Messes up the orders page for me so you can’t bulk edit orders or use any of the dropdowns.

    Doesn’t look like the developer is that interested as this was reported over a month ago.

    Version 0.7.1 of Shortcodes – updated 6 days ago by developers – does this fix this bug? I’ve read the details of the update but I’m not fluent enough in coding to understand it.

    Plugin Author goldenapples

    (@goldenapples)

    Yes, the problem as far as it’s been reported to me has been fixed in Shortcake 0.7.1.

    If you are using Shortcake and other plugins which depend on the ‘select2’ script, the fix for it is to make sure you’re updated to 0.7.1 of Shortcake, and add the following line to your wp-config.php file:

    `
    define( ‘SELECT2_NOCONFLICT’, true );
    `

    This will load the version of select2 which Shortcake depends on using a different name, so that it doesn’t conflict with any other plugins that need it.

    Will someone be able to tell me how I can configure it as also having this issue? The person who built my website is no longer in this field and I have no clue what to do.
    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Version 0.7.0 interferes with WooCommerce Products’ is closed to new replies.