Support » Plugin: PowerPress Podcasting plugin by Blubrry » Verify URL returns 403 Forbidden

  • I’m posting this because the other threads on exactly this topic haven’t helped.

    I don’t have any caching plugins installed; I disabled Jetpack; I have no firewalls; the plugin itself is setup correctly.

    Why, then, am I getting this error? It’s driving me insane.

    Any help is most welcome.

    • This topic was modified 3 weeks, 1 day ago by  biodagar.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Angelo Mandato

    (@amandato)

    Hello @biodagar,

    Thanks for using PowerPress!

    The verify feature in PowerPress does 2 things:

    • Performs a HEAD request to check URL is valid
    • Performs a byte range request to get the first 2MB of the file to read the ID3 tags for meta information including the duration

    Both the HEAD request as well as the byte range request is required for Apple podcasts.

    I ran the following command from a shell prompt to test for HEAD request support:

    curl -I https://www.biodagar.com/podcast/media/epsiode00.mp3

    For your media URL, this is what I got in return:

    HTTP/1.1 403 Forbidden
    Connection: Keep-Alive
    Date: Wed, 23 Oct 2019 02:44:26 GMT
    Server: LiteSpeed
    Vary: User-Agent
    Alt-Svc: quic=":443"; ma=2592000; v="39,43,46", h3-22=":443"; ma=259200

    It appears your web server LiteSpeed may be blocking HEAD requests. Common thing for old time server administrators to block HEAD requests, unfortunately this is not compatible with podcasting.

    I also did this command to check for range request support…

    curl -i -r 0-99 https://www.biodagar.com/podcast/media/epsiode00.mp3

    I get even more bizarre results:

    HTTP/1.1 301 Moved Permanently
    Connection: close
    X-Powered-By: PHP/7.1.32
    Set-Cookie: PHPSESSID=e7ee6644081d03561cc95825bd1bd5eb; path=/
    Pragma: no-cache
    Content-Type: text/html; charset=UTF-8
    Expires: Wed, 23 Oct 2019 03:55:05 GMT
    Cache-Control: max-age=3600
    X-Redirect-By: WordPress
    Location: https://biodagar.com/podcast/media/epsiode00.mp3
    Content-Length: 0
    Date: Wed, 23 Oct 2019 02:55:05 GMT
    Server: LiteSpeed
    Vary: User-Agent
    Alt-Svc: quic=":443"; ma=2592000; v="39,43,46", h3-22=":443"; ma=2592000

    Lastly I tried the redirect URL: https://biodagar.com/podcast/media/epsiode00.mp3 and it loads a WordPress 404 page.

    My only thought is that maybe you’re making changes to your site as we speak, switching from www. version to the non www. version and didn’t move the media file over?

    In a perfect world, the HEAD request with the capital “-I” should give you header information with a 200 OK response, and the request information lowercase “-i” plus the range request lower case “-r 0-99” will give you some binary data and a 206 partial response.

    I hope this helps.

    Thanks,
    Angelo

    Yeah sorry, I was still testing.

    Most of what you’ve just told me has sailed over my head. It’s a personal website, I’m not a tech-head, I don’t know what you’ve just told me.

    Any chance you can tell me how to solve it like I’m 10 years old?

    EDIT:
    The media is at this location: http://biodagar.com/wp-content/podcast/media/Epsiode00.mp3
    The plugin fails to verify.

    • This reply was modified 3 weeks, 1 day ago by  biodagar.
    Plugin Author Angelo Mandato

    (@amandato)

    Hello @biodagar,

    Same issue with the latest media URL location, it works in a browser when you click it into a new window but it does not work in the verify feature of PowerPress.

    I am not sure how to explain this with giving you a solution to move forward. Essentially where your website is hosted is preventing 2 key features that is required for Apple podcasts. Those features are called “HEAD requests” and “Byte range requests”. Sorry there is no other way to describe these terms. What I would do is contact your web host, point them to this thread and ask them to enable “HEAD requests” and “Byte range requests” so your podcast can be Apple compliant.

    Thanks,
    Angelo

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.