Support » Fixing WordPress » Verified WordPress 2.0.4 Problem With Firefox

  • Egad. Don’t hang me. I upgraded and clean installed WordPress 2.0.4 today for and encountered a very serious bug.

    In Firefox on three computers, I confirmed that the AJAX or Javascript fade+delete code fails. To reproduce, try to delete a category, link or post in the admin center in Firefox There is no fade and delete. You will get an error saying that you don’t have permission to delete. In Internet Explorer 6.x, the delete is successful with the effect. I tested cookie differences as well and still have this problem.

    For the time being, I downgraded to WordPress 2.0.2 and I don’t have this problem.

    Hope this helps some people.


Viewing 12 replies - 1 through 12 (of 12 total)
  • Did you ever think of using another browser to do the action, so as to not have to give up the security/bug fixes that are in .0.3 and .0.4?

    Um, yes. In my original post I mentioned that the fade+delete works in Internet Explorer 6.x

    I will have to weigh the security and stability of using Firefox against the version of WordPress I use.

    I encourage others to do the same. I just was pointing out a problem that occurs with the most recent, public, stable verision of Firefox and WordPress so others don’t have the frustration I had. I tried EVERYTHING including deleting my databases, tables and reinstalling WordPress.

    I’m just trying to help others.


    Just tested this with Firefox and WP 2.0.4 on my site. Clicking “Delete” on a post in the Manage page brings up a confirmation dialog, then the AJAX fade thing happens and the post is deleted. No errors, no permissions messages.
    This suggests the problem is something more specific to you.

    I’m with LesBessant – I ran the very same test, and have no issues.

    Do you have a script blocker extention in your firefox install (something like “NoScript”)?

    Typically, your best bet when feeling like there’s a bug with WP itself is to first come here asking if anyone else is experiencing the same problem, rather than to post that you have a “verified problem” and call it a “a very serious bug” without knowing for sure if it’s across the board, or just happening for you… just my $.02

    I ran the test as well. No problems.

    Thank you to the many people who tested this. I have uninstalled and reinstalled Firefox and still have the problem. However, I will try to adjust my settings to get this to work properly.

    Thank you for your feedback.


    heyadam, just wanted to let you know that I am currently experiencing AJAX problems with Firefox (Intel Mac) as well – not necessarily in WordPress, but in general. Although on my wife’s machine, running the same browser, certain AJAX pages work when they don’t on mine. I’m looking into some sort of extension conflict.

    A client of mine reported the same problem as heyadam, but with firefox on Kubuntu, and wordpress 2.0.4.

    His installed extensions: the GB language pack and colourful tabs 1.4.

    I tried it, also with ff on kubuntu, and both a clean version of wordpress 2.0.4, and was unable to replicate the problem without the colourful tabs extension. I also tested it after installing colourful tabs but was again unable to replicate the problem.

    I also tried firefox in a VMware virtual machine running windows 2000 on the same clean install of wordpress, with and without the colourful tabs extension installed, and was unable to replicate the problem in question.

    Both his and my test installs of wordpress were located on the same server — that rules out installed php modules.

    i acually did have the same problem, but i did a totally clean install (i deleted EVERYTHING! that was fun :p) and now it works.

    are you running one of those fancy themes or something?

    I found my problem was with a Firefox extension called Firebug. I was ctching all XMLHttprequests in their tracks to debug something and forgot to turn this off.

    I’m glad you got it resolved. I had a problem where 2.0.4 was hanging while posting. I also thought that Firefix was the culprit however it was actually related to having too many rpc’s listed in the updating service of WordPress. I removed all rpc’s except for pingomatic and technorati and the publishing is now blazingly fast.

    wp 2.0.4

    Upgraded yesterday and could not delete posts. Norwegian language pack otherwise comp. clean install ( I think, upgrade from 2.0.2.)

    However, in IE, no problem.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Verified WordPress 2.0.4 Problem With Firefox’ is closed to new replies.