Support » Plugin: Login by Auth0 » Ver 3.5.2 – SSO logging in doesn’t work after upgrade

  • Resolved daskm

    (@daskm)



    Hi,

    I have 2 websites connected through Auth0 WP plugin to the same client. Everything was working properly before upgrading to Lock WP plugin ver 3.5.2.

    After upgrading to ver 3.5.2 on the first site by following the upgrading method issued by the Auth0 team, I did not encounter any problems on the first site. (I don’t remember exactly whether there were any minor problems. It was couple of weeks ago.)

    Seeing that everything went well, I upgraded on the second site, and in the last step, it showed that “Review your Client advanced settings, specifically the Grant Types, and authorize your client for the Management API to manually complete the setup.”

    I tried doing that, but still the problem was not resolved.

    Few days ago, I exported the plugin settings JSON from both sites, and then I deactivated, deleted, and reinstalled the plugin on both sites. I also imported the JSON. Going through the documentation and other support requests again, I found that I had to update the link in both the sites’ plugins to the latest version of Lock 11, which I did as:

    //cdn.auth0.com/js/lock/11.5.2/lock.min.js

    Now the problem is that the SSO login doesn’t function. That means if I am logged in on one site, when I visit the other one, I am not automatically logged in. I have to login manually.

    But surprisingly, SSO logout functions. If I log out from one site, I am automatically logged out from the other too.

    (Both SSO login and SSO logout are enabled on both sites.)

    I found in my logs on the Auth0 dashboard this error:

    Failed Silent Auth
    Login required

    I would really appreciate a prompt help since after troubleshooting these problems on these test sites, I have to implement the same Lock upgrades in another 2 production websites that also use the same client.

    Thanks!

    daskm

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor Josh C

    (@auth0josh)

    Hi @daskm … sorry for the trouble and happy to help. A few questions for you:

    I tried doing that, but still the problem was not resolved.

    Are you referring to the notice in wp-admin about the grants? The best thing to do here is to review the Configuration page and make sure your Client matches. This section:

    https://auth0.com/docs/cms/wordpress/configuration#client-setup

    … and this one:

    https://auth0.com/docs/cms/wordpress/configuration#authorize-the-client-for-the-management-api

    Let me know if you have any questions there. If everything is configured correctly and you’re not having any login issues, then that banner should automatically go away. If not, there might be something else going on.

    That means if I am logged in on one site, when I visit the other one, I am not automatically logged in.

    When you visit the second one, are you going to the login page first? Can you check your JS console to see if you have any errors showing when you get there?

    I found in my logs on the Auth0 dashboard this error: Failed Silent Auth Login required

    That’s the error I would expect when that fails (silent auth is what’s happening on the login page when SSO is turned on). I just tried on my end with v3.5.2 of the plugin and the same version of Lock and did not have any issues. I tested this by:

    1. Logging in as an admin
    2. Turning on SSO and saving settings
    3. Go back to the homepage of the site
    4. Clearing my cookies for the site (this logs me out of WordPress but keeps me logged in at Auth0)
    5. Visit wp-login.php and I’m auto-redirected back to the homepage, logged in

    Let me know on the above and we’ll go from there. Thanks!

    Hi Josh.

    Thanks for the information and the test you did on your end.

    I am not logging in via the wp-login.php page. I am using the [auth0] shortcode on a page.

    The way you tested above works for me also. I found an interesting thing that when I login on any of the 2 sites first, the shortcode and the wp-login.php works. Only on the other site, the shortcode doesn’t work, but if I visit /wp-login.php or /admin, it logs me in automatically.

    But few problems like auto-redirection after login doesn’t work on the second site. It goes into the dashboard, which is not what I want. The user should go to a specific page on the site.

    Another problem is that on one of the sites, if it is the secondly-logging in site, then it logs in to the dashboard, but a rewriting error occurs in the URL leading to “Page not found.” eg. domain.com/sub/wp-admin gets rewritten as domain.com/sub/sub/wp-admin.

    Josh, what about this topic I submitted on the Auth0 community forum:

    https://community.auth0.com/t/lock-wordpress-plugin-ver-3-5-2-sso-logging-in-doesnt-work-after-upgrade/10839

    The problem is really frustrating. We were ready to launch our service backed by Auth0 SSO for all our service websites, and this upgrade is delaying the launch not just by days, but really by months… Whew! 🙁

    Can the Auth0 team come up with a REAL solution to this “not logging in via the shortcode” problem anytime soon? Not a temporary solution. A REAL one. Like a new upgrade or version? A temporary solution would not be feasible to us because after the sites are launched, then if any problem occurs, we might lose customers and have a bad reputation.

    Why was this deficit/shortcode problem NOT announced to Auth0 customers like myself?

    Please get a PERMANENT and REAL solution to this problem as soon as possible. I request you to give it the first and the top-most priority.

    Please get the solution done in few days. We would be extremely grateful.

    With hope,

    daskm

    Plugin Contributor Josh C

    (@auth0josh)

    @daskm

    I’m happy to help get this solved in a reasonable amount of time.

    It’s not terribly helpful to have multiple threads going for the same issue so I’m going to switch over to the Community link you posted.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Ver 3.5.2 – SSO logging in doesn’t work after upgrade’ is closed to new replies.