Support » Plugin: Wordfence Security - Firewall & Malware Scan » Vendors cannot login even though 2FA is disabled

  • Resolved sometimeska

    (@sometimeska)


    Hi,
    We have installed the free version of wordfence. 2FA is enabled for admin users only. we use woocommerce. my vendors are being asked to verify their login attempts via email but there are some logins that are shared by many of them and so it’s impossible. Also I don’t see why any and all logins have to be verified if they already exist? also they are being signed out of the site before they can finish working. Please help. Thank you.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support WFAdam

    (@wfadam)

    Hello @sometimeska and thanks for reaching out to us!

    Could you provide some screenshots of what you might be seeing? Also, the link you provided, is that login page that the vendors are using or do you have a separate woocommerce login page they are using?

    Can you send a diagnostic report to wftest @ wordfence . com? You can find the link to do so at the top of the Wordfence Tools > Diagnostics page. Then click on “Send Report by Email”. Please add your forum username where indicated and respond here after you have sent it.

    Thanks again!

    Thread Starter sometimeska

    (@sometimeska)

    Hi,
    thanks for the reply. The vendors are using that link, as far as I know, but people have a funny way of doing things sometimes. I can’t replicate their issues unfortunately but have sent a diagnostic mail to you. We also have about 600 regular customers who login using the pop up window on our home page movingon.co.za. I’m not sure why any of these people are being asked to authenticate via email, as 2FA is not enabled for anyone except admins. My mail logs show numerous emails sent from wordpress@movingon.co.za asking my agents to click on a link to verify. The link expires, as you know, and many of them (they use gmail) say it takes too long to receive the mail. Is it possible to extend the expiry time of that link? Thanks for your help.

    Thread Starter sometimeska

    (@sometimeska)

    Also, I have created individual logins for all agents across the board, so that there are no longer multiple attempts from different ips to log in to the one author account on wordpress. They also have their own shop vendor accounts as well, which we use wclovers and woocommerce for. Hope this all makes sense.

    Thread Starter sometimeska

    (@sometimeska)

    I have sent the diagnostic mail but still no reply from you? We continue to have problems with slow delivery of mail. Is it possible to extend the 15 minute time limit?

    Plugin Support WFAdam

    (@wfadam)

    Sorry for the delay!

    Thanks for sending that diagnostic!

    I was doing some troubleshooting on your site and I believe I might have found the issue. When it comes to the WooCommerce Login Security integration, We are looking for an element with the ID primary and that is where we are appending login messages. We check that there is a .woocommerce element, but we don’t make sure #primary exists. This is something we are changing in a future release.

    If you add a div on the page with id="primary" the messages should be displayed there. It should be added by WooCommerce by default, so it might be getting overridden by your theme. If you need to, reach out to your theme provider and they should be able to add this div.

    I hope this helps!

    Let me know what you find!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Vendors cannot login even though 2FA is disabled’ is closed to new replies.