Support » Plugin: Vendi Cache » Vendi Cache not creating cache files

  • I’ve enabled the disk based cache. I test each page and come back to vendi-cache settings and the cache stats say, “Your cache is empty. It may be disabled or recently cleared”.

    I tried disabling wordfence. Although it doesn’t look like falcon is there anymore. I even tried adding the plugin to a site without wordfence. That still didn’t work. Any ideas?

    Thanks –
    Jay

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor cjhaas

    (@chrisvendiadvertisingcom)

    Hi Jay,

    The cache is over-sensitive when it comes to PHP errors. Currently if it detects any PHP error, even a warning, it won’t cache the current request. There was an edge case where someone had a error that didn’t happen too often and was caused by a third-party website but we happened to cache that specific request which resulted in everyone seeing that error message.

    We’re planning on addressing the sensitivity soon but I’m 99% certain that this is your problem. Mostly likely there’s some plugin on your site that’s generating a PHP warning which is deactivating the cache for the given request. And most likely that plugin is running on every cache so the cache if effectively disabled.

    We’re also thinking about adding logging options to help troubleshoot things but for now if you temporarily set WP_DEBUG to true you should be able to see what’s causing the request to not be cached.

    Thanks,
    Chris

    First- Thank you for the fast reply! Looking forward to the future of this plugin.

    So – I had some pesky debugging that I’ve been meaning to resolve. Got that done. There was an error due to a typo in the permalinks. Also resolved.

    I’ve turned on DEBUG, _LOG and _DISPLAY. None are showing any problems.. yet I still don’t have any cache files. I did get a file called “test.php” that contains “test”.

    Thoughts?

    Thanks –
    Jay

    Is this true even for silent php errors? Our server does not have error reporting enabled but the plugin does not create any cache files.

    Updating this issue. I found the reason the cache didn’t cache pages on our development platform. It was due to the plugin Widget Logic. I disabled that and things started working both with Twenty Seventeen and our custom theme.

    However, doing the same things on our production platform did not solve the issue. On the production platform, we’re using https. Might that be an issue?
    The cache did not work with Twenty Seventeen or our custom theme.

    Plugin Contributor cjhaas

    (@chrisvendiadvertisingcom)

    Hi @zaewin, I apologize for missing your original post.

    The logic for disabling the cache is wired into PHP’s native error/exception handling. If PHP raises an error or throws an exception, even if it is silent, we still disable the cache. At the trap level there’s no filter that we can set so we have to rely on filtering it at the handler level and unfortunately we haven’t had time to look into this further yet. We still recommend looking through your debug logs to see if you’re getting any errors or warnings.

    Once we add the capability to cache pages that have silent errors (that phrase still scares me) we’ll let everyone know.

    Thanks,
    Chris

    Hi and thanks for the answer! We did get it to work in development as I described in my follow-up post. However, on our production server with https, the cache does not work.

    When I try to debug the functions in the plugin, they all seem to return true but nothing is cached. I’m still looking into it but maybe you could point me in the right direction in regards of the https vs. http problem?

    Plugin Contributor cjhaas

    (@chrisvendiadvertisingcom)

    Sorry, I meant to address that but got distracted!

    There is a checkbox in the backend that is _not_ checked by default that disables caching for HTTPS sites. As long as that’s checked, there’s nothing else in the code that cares one way or another about HTTP or HTTPS. That checkbox is from before things like Let’s Encrypt became big and is something we’re considering changing for new installs or at least explaining a little better.

    I would estimate that about 90% to 95% of the sites that we build and maintain run over HTTPS so we’re very confident that there isn’t an issue there.

    Hi again!

    Did find some php notices on SOME pages. I’ve fixed them and checked and re-checked the error logs and nothing is reported by php.

    Still, caching does not work and the only difference between the development platform where caching works and the production platform is the HTTPS.

    The HTTPS checkbox you mentioned is checked. Should it not be?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Vendi Cache not creating cache files’ is closed to new replies.