Support » Fixing WordPress » vCard and WordPress – compatibility issues ?

  • Resolved joerc

    (@joerc)


    Hi, everyone.

    Just two days ago I tried to upload my vCard file to my WordPress site and received an error message stating this file type is not supported for security reasons.

    Is this a WordPress problem or is it related to my website’s hosting service ? My WordPress site isn’t hosted by WordPress but by another third party service (in my case GoDaddy) in case this information is relevant.

    Are there any known compatibility issues between vCard files and WordPress sites or is this related to my hosting service ?

    Thank you in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • andrewmills

    (@andrewmills)

    WordPress has a list of specific file types/extensions that it will allow you to upload– but .vcf is not on the default list.

    Most likely, you’ll need to add some code to your functions.php file:

    This support article should help with the particulars.

    joerc

    (@joerc)

    Hi, Andrew.

    Thank you for your really helpful reply. I followed the link you provided and added the code provided on the other thread you referenced to my functions.php page. That solved the problem. As soon as I did I was able to upload my vCard file to my WordPress website.

    Thank you very much again for your helpful and prompt reply.

    Joe.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘vCard and WordPress – compatibility issues ?’ is closed to new replies.