Support » Plugin: All In One WP Security & Firewall » Varnish with Proxy Config locks out localhost

  • Resolved ctevwordpress

    (@ctevwordpress)


    Referencing unresolved topic: Here

    I am having the exact same problem after setting up varnish with SSL termination, all ip address references default to 127.0.0.1 and using Varnish with a reverse proxy set up: Apache :443 -> Varnish :8080 -> Apache :8181 (backend)

    The plugin’s “Logged In Users” tab shows all localhost ip addresses, no longer detecting the actual IP address origin. The result is login lockdown, which I’ve now disabled, is locking out localhost/every user.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    I am not sure if this will help you or not but I think it is worth a try.

    Go to WP Security -> Settings -> Advanced Settings and test different options available.

    Let me know how you go.

    Thank you

    Thread Starter ctevwordpress

    (@ctevwordpress)

    Thanks, this worked (HTTP_X_FORWARDED_FOR)

    Plugin Contributor mbrsolution

    (@mbrsolution)

    That is great news 🙂 I am marking this thread as resolved.

    Enjoy the plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Varnish with Proxy Config locks out localhost’ is closed to new replies.