Support » Plugin: Page Builder by SiteOrigin » Various errors

  • Resolved atutrabajo

    (@atutrabajo)


    Dear: Good morning.

    I keep informing you that, for some time now, when I try to edit certain blocks, it leaves the editor and it shows me a screen with a white background and, with the day and time.

    I gave intervention to the support of my hosting (Mochahosta) who, after an exhaustive search, could find the following error …

    …”After further review, it appears that the original issue reported is related to a 3rd party application, for which we are unable to offer additional technical assistance. Here is the actual error message generated by the ModSecurity:

    [Sat Nov 14 21:30:39.703064 2020] [:error] [pid 1743745:tid 47267642652416] [client 2800:810:4b7:8016:3c52:3a8a:787c:e4a0:0] [client 2800:810:4b7:8016:3c52:3a8a:787c:e4a0] ModSecurity: Warning. Pattern match “(?i)(?:]*?>[\\\\s\\\\S]*?|(?:=|U\\\\s*?R\\\\s*?L\\\\s*?\\\\()\\\\s*?[^>]*?\\\\s*?S\\\\s*?C\\\\s*?R\\\\s*?I\\\\s*?P\\\\s*?T\\\\s*?:)” at ARGS:instance. [file “/etc/apache2/conf.d/modsec_vendor_configs/OWASP3/rules/REQUEST-941-APPLICATION-ATTACK-XSS.conf”] [line “65”] [id “941140”] [rev “3”] [msg “XSS Filter – Category 4: Javascript URI Vector”] [data “Matched Data: found within ARGS:instance: {\\x22title\\x22:\\x22\\x22,\\x22text\\x22:\\x22\\xa0\\x0a\\xa1S\\xed. Esto me interesa!\\x0a\\xa0\\x0aDeja tus Datos y ser\\xe1s de los 1ros. en enterarte de lo qu…”] [severity “CRITICAL”] [ver “OWASP_CRS/3.0.0”] [maturity “1”] [accuracy “8”] [tag “application-multi”] [hostname “atutrabajo.org”] [uri “/wp-admin/admin-ajax.php”] [unique_id “X7CSz-iCo@nUiYz3er69VAAAAoc”], referer: https://atutrabajo.org/wp-admin/post.php?post=990&action=edit#…

    By last.

    Surely you must already know that, ALL of us who use the wonderful plugin, are having problems with the “results” emanating from the Yoast plugin.

    In other words, to ALL of us who build our site with your visual layout maker, Yoast’s traffic lights that were green before, are now red.

    Por favor: Podrían responderme a la mayor brevedad posible, cuanto podrían en demorar en resolver, aunque más no sea el 1er. problema descripto ???
    De esta forma, podré recontactar a mi proveedor de hosting antes de que cierre el ticket y, si hay algo que explicar, me gustaría que lo agreguen (literal) pues, YO no entiendo ingles 🙁

    Aguardo sus comentarios.

    Desde ya, muchas gracias.

    ¡Saludos!

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi, thanks for reaching out.

    Please, send us an export of the page so we can take a look. You can do this by clicking on the three vertical dots in the top right of your screen when editing the page. Switch to Code editor. You can send us the contents using https://pastebin.com/ or by adding the contents to a text file and uploading it to Drive/Dropbox/WeTransfer and sending us the link.

    atutrabajo

    (@atutrabajo)

    Hi. Thanks for answering.

    On the 1st. place and, with respect to:
    … “Please send us an export of the page so we can take a look at it. You can do this by clicking the three vertical dots at the top right of your screen when editing the page.” …

    I do not know how to do that but, I am going to show you step by step, in the following screenshots, what is happening and then, I am going to do the same with the source code, to see if that can help to locate the problem.

    And, regarding …
    … “Switch to the code editor. You can send the content to us using https://pastebin.com/ or by adding the content to a text file and uploading it to Drive / Dropbox / WeTransfer and sending us the link” …

    It does not make much sense because, precisely, the problem is generated when, precisely, I am using the visual layout of v / plugin.

    In other words, when I am in the classic editor this does not happen.

    Shall we start?

    – Capture 1:
    Note that the last article (which does NOT have Page Builder activated except in a single block) has 1 red traffic light and another green one.
    On the other hand, the previous one (done ALL with the visual layout of v / plugin) is in red.

    https://www.dropbox.com/s/wz63k3n6fzs4ip2/Captura%20de%20pantalla%202020-11-16%2010.16.42.png?dl=0

    – Capture 2:
    I enter my last article (made with the Classic Editor, except the last block) …

    https://www.dropbox.com/s/2532zz3g78vb7pn/Captura%20de%20pantalla%202020-11-16%2010.19.40.png?dl=0

    The only “claim” Yoast makes to me is that …
    … “Keyphrase in Title: The exact match of the focus keyphrase appears in the SEO title, but not at the beginning. Move it to the top for best results” …
    But that is a “trick” that I do on purpose with ALL SEO titles, so that they are noticed a little against so many results in Google.

    Specifically in this case, I mean this …
    ▷ How to Make a Curriculum 🏅 Effectively SUCCESSFUL!

    Although in this editor it is not noticed but, the symbols (at the beginning and at the end of the key phrase, are icons to be noticed in Google.

    – Capture 3:
    I enter one of the articles with “problems” (Edited within the Site Origin layout)

    https://www.dropbox.com/s/a227helfna6gr9i/Captura%20de%20pantalla%202020-11-16%2010.27.20.png?dl=0

    Notice in the right column that both Yoast items appear with problems

    On the other hand, the block that I am pointing to (and that I will try to edit next) is the only one that I have problems with.

    But, since I’m here, I’m going to go further down and, in the next screenshot, I’m going to expand on the “results” that Yoast says this article has …

    As you can see, among other things it says that …

    … “Outbound Links: No outbound links appear on this page. Please add some!” …

    … “Internal Links: There are no internal links on this page, be sure to add some!” …

    … “Key phrase in introduction: Your key phrase or synonyms do not appear in the first paragraph. Make sure the topic is immediately clear” …

    … “Text length: text contains 0 words. This is well below the recommended minimum of 300 words. Add more content” …

    Which is a total absurdity. Especially the last point that indicates that my article … “Has NO Words !!!

    – Capture 4:

    Now I’m going to “get into” the source code for this part to see if this helps anything …

    https://www.dropbox.com/s/rq3nrpmlnu5438h/Captura%20de%20pantalla%202020-11-16%2010.36.29.png?dl=0

    Finally, I will enter the block in question to try to edit, then I will show you the “result” of that action and, finally, the source code of said “result” …

    – Capture 5:
    The “result” when clicking Edit that block …

    https://www.dropbox.com/s/b4gvsweds8tcy0e/Captura%20de%20pantalla%202020-11-16%2010.38.48.png?dl=0

    – Capture 6:
    The source code for the screen that was generated as a “result” of the Edit … action.

    https://www.dropbox.com/s/wg2yu0lsc82rqgx/Captura%20de%20pantalla%202020-11-16%2010.41.01.png?dl=0

    I hope this information can be useful to help you solve both problems (The Edit plus the Results in Yoast SEO)

    I await your comments.

    Thank you very much.

    Plugin Author Andrew Misplon

    (@misplon)

    For the moment, let’s focus on the block error and try to help you resolve that. Once that’s resolved we can look at Yoast issues.

    – Capture 5:
    The “result” when clicking Edit that block …

    Please, send us the export of this page, here is how: https://imgur.com/a/6g8fyNo. Scroll down in the Imgur post, there are three screenshots showing how to access the code view of the problem page. Once you’ve copied the code from the problem page, upload it to Pastebin, send us the link, we’ll test locally with the code and go from there.

    Thanks

    Estimated:
    Honestly, I don’t know how to do what you say. And I explain why:
    As for …
    … “send us the export of this page, this is how: https://imgur.com/a/6g8fyNo” …
    This is impossible to fulfill because, as I can see, the example you use is made in the Classic WordPress Editor.
    Instead, I have ALL my articles and pages, built with the Page Builder layout by Site Origin.
    And, when I want to Revert to the Classic Editor it asks me …
    Would you like to clear the content of your Page Builder and use the standard visual editor back?
    Something that, of course, is not going to happen because, I am not going to DELETE the 3290 words that the article has to fix a line of code.

    And the same goes for …
    … “Scroll down the Imgur post, there are three screenshots showing how to access the code view of the issue page” …
    As I said, my post was created from scratch within the Page Builder visual layout and, there is NO way to reverse that, without deleting ALL the content.

    Ah. By the way, I can tell you that, a while ago, I made a similar proposal to the Yoast Seo developer who, like a lot of (too many) of those we complained about, suggested us (among other things that …
    … “Deactivate all plugins – except Yoast – and activate them one by one to find the conflict” …
    Tired of looking for solutions, I listened to him and … soooo! The traffic lights turned green again.

    So I started activating them one by one, leaving for the end, the 2 “suspects” (the Page Builder and the Caché). And guess what … I was able to edit the classic editor just fine! But …

    When I finished activating all, I activated the cache (W3TC) to take advantage of cleaning and, only at the end of the Page Builder.
    And 2 (two) things happened:
    1) All traffic lights turned red
    2) All the changes I made in the Classic Editor “disappeared” !!!
    Ergo, I stopped trying, I communicated it to the Yoast developer (who by the way “assumes” that the conflict is Page Builder with Yoast and not the other way around, heh!) And, frankly, I’m hoping that, some of the 2 (or both), find a solution.
    But going back to our business, I was telling you that I can’t operate as you suggest but …

    The best I can do is send you the link to the source code of the article in question, which you can check by following this link;

    view-source:https://atutrabajo.org/como-elaborar-perfil-profesional-adecuado

    I hope you find it useful

    I await your comments.

    Greetings.

    PS: It would not make much sense to deactivate the Page Builder plugin and do as I did that time, because, as I said, I could actually edit but, as soon as I reactivated the plugin, there was NO change to the ones I made in the classic editor.
    And, of course, the source code would not contain anything that refers to Page Builder. Ergo, it would not make practical sense for your analysis.

    P.d 2:P.S. 2: I swear I copied and pasted the link as is from my browser but for some reason it doesn’t take it.
    The concrete thing is that, when I go to my article and, I give: Right button / See source code that link appears. I dont know. Hope this can help you. See you.

    Plugin Author Andrew Misplon

    (@misplon)

    The screenshots I sent are clearly using the Block Editor: https://imgur.com/a/6g8fyNo. Those screenshots are not from the Classic Editor.

    Not a problem, let’s try starting over.

    Your website is producing a series of JavaScript errors relating to CloudFlare’s Rocket Loader. Here are the errors https://imgur.com/a/jqDcOhW. Here is how to view them yourself https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis. Let’s start by resolving all JavaScript errors on the page, there shouldn’t be any errors present in a live site. The errors might not be related to the Yoast issue but it’s worth eliminating them as a problem. Do the errors resolve when you deactivate W3TC?

    Hi. A thousand apologies for not answering you before but, I was doing a little research based on what you mention, and I came to the following conclusion:

    But first, you need to know a bit of history to put yourself in context.

    Rocket-Loader, is a Cloudflare script that serves precisely to … “Improve the initial loading time of pages that include JavaScript”

    Some time ago I installed it on my site to, precisely, solve the “famous” PageSpeed ​​message that says … ”
    Remove resources blocking rendering “…

    Although, in truth, it is not that I installed it a priori.

    What happened was that PageSpeed ​​mentioned it as one of the many external resources (Rocket Loader actually operates directly from Cloudflare), which blocked the first rendering of the page.

    And obviously, the code I installed, to solve cloudflare and other assets (css and js), worked. That is why it remained. But …
    When you mentioned the rocket-loader “product” bug, I started looking for information and, since I couldn’t find anything to solve the problem, I decided on a radical “old-fashioned” “solution”. And, following the saying of, “dead dog the rabies is over”, I tried removing the code from my site and … soooo!

    Then I measured, measured and re-measured and, guess what … Rocket Loader No Longer Needed to Install on my site! Why? Well, because I guess the folks at Cloudflare must have gotten quite a few complaints about this “side effect” and they’ve obviously fixed it already. I mean, I still have Cloudflare on my site but, as always, externally. But, contrary to when I installed it (back in 2019) now … It DOES NOT block rendering of my site anymore!

    Ergo. And that’s why I waited until so late to answer you … There is NO LONGER trace of rocket-loader on my site anymore!

    However. Although I searched and searched my ENTIRE directory, with a plugin called String Locator that, what it does is, precisely, search for a phrase in the ENTIRE site, the phrase rocket-loader is mentioned ONLY in 2 caches: This ; wp-content / cache / page_enhanced / atutrabajo.org / topic / tips-to-get-job / _index_ssl.html_old and, this other; wp-content / cache / page_enhanced / atutrabajo.org / project-de-vida-profesional / _index_ssl.html_old

    And both cases, as you may have noticed, are about archives; cache, minimized and, old (old). And, they still are because, even though, like I told you, I cleaned and re-cleaned my caches, the fucking word (rocket-loader) clung like a tick to those two files. But, give my cache plugin (W3TC) one more time, for sure, for tomorrow, there is NOTHING left.

    And speaking of W3TC and, in relation to the question you asked me earlier. The answer is no. If I disable W3TC the problem is NOT fixed. What’s more, I mentioned something to you in my presentation of the problem because, as I told you, once (following the recommendations of the Yoast developer), I deactivated ALL the plugins (except for Yoast, obviously) and, I reactivated them one by one to see which conflicted with Yoast. And I left (on purpose) for last, my 2 suspects. These are precisely W3TC and Site Origin Page Builder. And, as I think I also told you …

    When I also reactivated the penultimate one (W3TC), EVERYTHING was still working OK but … As soon as I reinstalled Page Builder, wham!

    Anyway.

    Now to finish, what we have is that:

    – It is NOT W3TC

    – NOT Yoast

    And now, it’s not Rocket-Loader either.

    And yet it still DOESN’T let me edit !!!

    Plugin Author Andrew Misplon

    (@misplon)

    And yet it still DOESN’T let me edit !!!

    Please, go to the page that you aren’t able to edit. Open the browser console, here is how. Take a screenshot of the page and the browser console, upload it to any online image storing site and send us the link.

    Thanks.

    Hi Andrew.

    First of all, thank you for your patience.

    That said and, I continue with the “odyssey”, I tell you that …

    – About …
    … “go to the page you can’t edit. Open the browser console, here’s how. Take a screenshot of the page and browser console, upload it to any online image storage site, and send us the surround “…
    Well, here you go, the code of the Entry with which, currently I have problems;

    https://www.dropbox.com/s/os8rtvwjybz3ss4/Captura%20de%20pantalla%202020-11-20%2009.32.12.png?dl=0

    As you can see, rocket-loader still appears.

    But this is because, now that I have just checked that, in ANY part of my site, there is a single reference to this expression, it turns out that, as always …

    This is an external call to Cloudflare that is activated as soon as you enter my site!
    And there, then, I can do nothing.

    That is to say…

    Or I choose to disconnect the excellent rocket-loader service that Clodflaure offers me for FREE, which helps me serve my assets (JS and CSS) a little faster (so imagine if I didn’t have a rocket-loader, heh). ..

    Or I choose to disconnect your plugin.

    So I do not know. I leave to your judgment.

    I await your comments.

    Greetings.

    Pd: In other words, if your theory is correct, in that that error is the one that “triggers” the problem, here I show you the same “open” so that you can see what, in reality, it is “questioning”. ..

    https://www.dropbox.com/s/4i5wz2tis86c07r/Captura%20de%20pantalla%202020-11-20%2009.40.02.png?dl=0

    And I’m not a “programmer” (and I also “hate” them, heh!) But, from what little I understand it says that …
    … “Undetected reference error: jQuery is undefined
    in <anonymous>: 1: 1 “…
    And when I click on <anonymous>: 1: 1, I get this …

    https://www.dropbox.com/s/3nxgt9ssqpqk63f/Captura%20de%20pantalla%202020-11-20%2009.47.46.png?dl=0

    I hope it helps you to clarify this problem.

    From already thank you very much.

    See you.

    Plugin Author Andrew Misplon

    (@misplon)

    Hi, we’re looking to see what errors are present when you edit the page in WordPress, not on the site front-end, the screenshots above appear to be of the site front-end. Sorry, my request wasn’t clear. Kindly, email our premium support desk at support@siteorigin.com, we’ll assist directly to speed things up. Thanks.

    Hi Andrew.
    And yes, you’re right, said screenshots are from the front-end (as you mention).
    Although, strictly speaking, I have NO idea what difference there is and / or which is which, heh.
    That said if, as I suspect, the back-end is my Administrator Panel, here it goes, a screenshot of the code for it …

    https://www.dropbox.com/s/e5zuyckj25v47qs/Captura%20de%20pantalla%202020-11-20%2011.22.02.png?dl=0

    And before you tell me that the “responsible” seems to be the Yasr plugin (which adds “stars” to my articles), let me remind you of 2 (two) things …
    1) The test I did a while ago in which I deactivated ALL my plugins (including Yasr) and then activated them one by one.
    2) I also have problems with this page …

    https://www.dropbox.com/s/ter18o1y3izuuzj/Captura%20de%20pantalla%202020-11-20%2011.26.38.png?dl=0

    And in it, despite what the console says, there are NO stars.

    Ergo. The console is probably taking the “implicit” code directly into the WordPress Dashboard for my ALL site.

    The one that makes, whether or not you use the “stars” in an article or page, Yasr makes them “available” even if you want to rate an article or page, directly from the Administration Panel.

    I never use it but, I suppose it could be useful, for example, if I had several editors and I liked a page or article that they have written for me.
    But, it is not the case then, the only one who: Manage, Write, Edit here, it’s me, heh!

    Finally and as for …
    … “email our premium support service” …
    Just in case I can tell you that I am NOT “premium”.
    In the sense that, I have the free version of v / plugin installed.

    I hope this info can be useful to you.

    I await your comments.

    Greetings.

    Plugin Author Andrew Misplon

    (@misplon)

    Kindly email support@siteorigin.com, we’ll assist directly. Thanks.

    Good. Since you insist even though, as I told you …

    … “I’m NOT premium” …

    I just sent you an email with the subject:

    … “Miscellaneous errors. Reference: support / topic / various-errors-8 / # post-13688584” …

    See if you received it and, “let’s start” whenever you want, give it?

    See you!

    Plugin Author Andrew Misplon

    (@misplon)

    Thanks, we’ll assist further via email.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.