[resolved] Variations not working (8 posts)

  1. graphmaster
    Posted 2 years ago #

    My site at http://albuquerquedukes.com/merchandise had been working fine. THe client updated some merchandise, and now the variations (such as changing shirt color) stopped working at all.

    I have them all set up with Used for Variations selected, each color has their own image uploaded, but when you change shirt colors, the image to the left isn't changing?

    I am sure it is probably something easy that I am missing, but I can't see it.

    The user and password are testing and testing.

    Any help is greatly appreciated.


  2. vark
    Posted 2 years ago #

    You've got a JS error which will prevent variation pricing from working:

    Timestamp: 10/20/2013 10:31:42 AM
    Error: TypeError: e.cookie is not a function
    Source File: http://albuquerquedukes.com/merchandise/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=2.0.17
    Line: 1

  3. graphmaster
    Posted 2 years ago #

    What would have caused this and can I fix it?
    Thank you for the prompt response as well.

  4. vark
    Posted 2 years ago #

    Not sure how to proceed except perhaps to try the deactivate dance - change the theme to 2012, deactivate all plugins but woo, test, add 1 back, test, etc... Then just stop using the conflicting item once you've identified it, or address the conflict with the developer of the conflicting item.

  5. Julie
    Posted 2 years ago #

    Graphmater - I'm in the same boat! If you figure it out, please share! I will do the same!

  6. romulobritta
    Posted 2 years ago #

    I had the same problem after update the plugin. Here is the solution that worked for me: http://docs.woothemes.com/document/jquery-cookie-fails-to-load/

  7. dami5
    Posted 2 years ago #

    I have a similar issue the prices from the variations I set up are not updated anymore. All I did was update from woocommerce 2.0.14 to 2.0.17
    I tried the jquery cookie changes but that did not work =(

  8. graphmaster
    Posted 2 years ago #

    I got it to work by removing the plug in, then loading version 2.0.14 That is what the theme writer recommended and it works now. The only issue now is if I try to use the Recaptcha with Theme My Login it doesn't work. If I disable Woocommerce, it works. I will just need to live without the Recaptcha

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.