Support » Plugin: Smart Variation Swatches for WooCommerce » Variations not saving

  • When I add a new product and I use the usual procedure to add an attribute, the attribute appears to be added, but when I save and go back to view it the attribute is not actually saved. I have an attribute called “brand” which is not used for variations, this attribute seems to save no problem. However, when I try to add the attributes for size or colour (which are used for variations), then these are the attributes that do not save. I have tried this on existing products, and also on new products. When I disable the variations swatches plugin then the size & colour attributes save just fine.

    This worked when I first installed the plugin, it just seems to be sometime in the past month that one of the updates seems to have broken things.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I don’t have a fix but I think this is related to two deprecated functions get_parent() and get_post_data(). I’m probably going to try another more updated plugin since I’m working on a new site and just getting started. If not I may try to figure out how to make this WC3.0 friendly. Hopefully the developer will fix it soon.

    biosyntheticdesigns

    (@biosyntheticdesigns)

    @bestrafung83 I can’t find those two I tried to find the issue but without any luck.

    If anyone has ideas what can be causing this please ping me here.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Variations not saving’ is closed to new replies.