Support » Plugin: WooCommerce » Variations endless spinning

  • Resolved tripatwhat

    (@tripatwhat)


    Hello,

    when we try to add a variation to our product, we get endless spinning wheel.

    Besides that, there’s an error in console: TypeError: a(…).selectWoo is not a function.

    We’ve deactivated all plugins and activated Twenty Nineteen theme. This didn’t help.

    We are using latest WC.

    Can you please help?

    Thanks

Viewing 15 replies - 1 through 15 (of 16 total)
  • Stef

    (@serafinnyc)

    It sounds like you may have a custom theme that requires a specific plugin. There’s not much info to go on here. Do you have a URL that you can share?

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @tripatwhat

    Did you get to the bottom of this? We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

    Thanks,

    Hello @dougaitken,

    we still didn’t solve this issue yet.

    Can you please help us out?

    Regards

    Just to mention, we also tried activating Storefront theme, but it didn’t work.

    We tried the solution from this thread: https://wordpress.org/support/topic/endless-spinning-wheel-2/, also didn’t help.

    We tried installing classic editor plugin to disable Gutenberg, because we thought that maybe Gutenberg is causing problems, but this also didn’t help.

    So, right now we are out of ideas and we hope that you will write back soon and help as out with this strange issue.

    Stef

    (@serafinnyc)

    Make sure you’re not using any plugins when you’re doing this. Any plugin that minimizes JS or from the server might be causing conflicts with the Ajax.

    Just make sure you have all plugins disabled except for WC and you are testing in Storefront or another default theme.

    @serafinnyc Like i said in my first post, all plugins are disabled besides WC. Storefront is installed and activated. I tried that one and twenty nineteen.

    Something else is wrong here, but i can’t get to any WC developers to give me a hand regarding this. It’s so annoying.

    Stef

    (@serafinnyc)

    You misunderstood. Just because you disabled a plugin doesn’t mean the issue isn’t stuck in cache.

    My statement specifically refers to minifying of the js and or css with a focus on js. Your initial error refers to a js issue. So, despite disabling every plugin…were any of them an optimization plugin? Because that’s usually the cause here.

    However, you’re not really giving us a lot to go on here. The last resort is to post your system staus report with everything the way it was so @dougaitken or one if us can review. You can remove the url from it if you want as it appears you don’t want to share it. Then paste it here.

    I meanwhile did some further testing with clean WP and WC, with imported products from this website and everything works normally.

    I then connected this fresh WP with old DB and again variations work as usual.

    So, now i am trying to figure out what exactly is causing problems in files. I will check further and get back later.

    Thank you

    Stef

    (@serafinnyc)

    I think something changed in the way the variations get written to the DB now. @dougaitken can you confirm? I thought I saw something somewhere on that.

    This could be the cause but I’m not positive.

    I’ve checked folders, cleared out the cache through the plugin we use since the beginning of this website and we use it on all other websites (Fastest Cache).

    Client was using some other optimization plugin (Hummingbird), but this plugin is removed long time ago.

    This is looks to me as something went wrong during WP or plugin update.

    You mentioned system status report. Where can i get this in WP backend?

    Stef

    (@serafinnyc)

    Go to WooCommerce > Status > Get System Report and paste it here. It might get flagged as spam but be patient, it’ll get approved soon.

    Maybe it won’t be necessary. I found some files left by Hummingbird plugin deep inside wp-content and uploads folder. Stupid plugin didn’t delete files and folders behind itself. I removed everything connected to it and now everything seems to be working.

    Client will test it on his side, but it looks like it’s ok now.

    Thank you very much for your help. It is much appreciated. 🙂

    Stef

    (@serafinnyc)

    There you go. The files/folders won’t be deleted just in case you install it again. Any issues best to have them test in private or incognito browser so cache doesn’t play a role.

    Plugin Support dougaitken

    (@dougaitken)

    Automattic Happiness Engineer

    HI @tripatwhat

    I’m really happy to see that @serafinnyc guided you to a possible solution here.

    I found some files left by Hummingbird plugin deep inside wp-content and uploads folder. Stupid plugin didn’t delete files and folders behind itself. I removed everything connected to it and now everything seems to be working.

    Can you reach out to the Hummingbird team to ask about clarification on this? I know many plugins, WooCommerce included, don’t delete all the plugin files upon plugin deactivation and deletion. With WooCommerce specifically, you need to add a small piece of code before deactivating and deleting WooCommerce for it to “clean up” after itself – https://docs.woocommerce.com/document/installing-uninstalling-woocommerce/#section-4

    This is looks to me as something went wrong during WP or plugin update.

    Yes, we’ve seen this before but don’t have an exact replication – it is often related to caching or minification plugins which during the 3.6 update, the database tables aren’t updated correctly.

    Client will test it on his side, but it looks like it’s ok now.
    Thank you very much for your help. It is much appreciated.

    If everything is sorted now, I’ll leave the thread for you to mark as Resolved yourself this time.

    Thanks,

    Hello @dougaitken,

    sorry, but at the moment i have other things to take care of. I can’t spend time contacting the plugin authors and debug this with them.

    As @serafinnyc previously said, WC can get into a problem with Ajax, if there is some minifying of JS going on. So maybe WC should be tested further with main caching plugins and WC developers to communicate with authors of these plugins to find some mutual solution, since unfortunately plugins are leaving their things behind and causing problems.

    Best regards

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.