Support » Plugin: WooCommerce » Variations and New Product Save Issues

  • Hi everyone,

    I’m currently using the most recent versions of WP 3.5.2
    and Woocommerce 2.0.12

    Issue 1:
    When you try to add a product to the cart that has a variation, you get an error “Please choose product options…” All of the other non-variation products work fine.

    While I’ve been trying to fix the issue, I’ve deactivated all of the plugins, and I’m using the Twenty Twelve theme ver 1.1

    I had setup our site ( while ago when I was recently told we were having an issue with the products (flipflops) that had a variation. Unfortunately, I’m not sure if they ever worked properly.

    On this product, I’ve tried with and without having a default option set. I’ve deleted the attributes and variations and started over, but there was no change. I’ve also noticed the clear selection works fine. The variations have been added from the global selections, and manually, neither has worked.

    Issue 2:
    After reading that we may have needed to save the product before the variations are set, I attempted to create a test product to see if that would work.

    I’m able to save a simple new product with no issue. However when that product is switched to a variable I get an error, when I try to save.

    PHP Warning: Invalid argument supplied for foreach() in C:\Websites\RS_Websites\\wp-content\plugins\woocommerce\admin\post-types\writepanels\writepanel-product-type-variable.php on line 824

    I get this error when I save without adding attributes, and after I’ve selected attributes. If I go ahead and also add the variations, it saves fine (however I don’t believe you’re supposed to do that). I also get the error, if I don’t save it initially as a simple product.

    this is the code on line 824 and 825

    foreach ( $attributes as $attribute ) {
    if ( $attribute[‘is_variation’] ) {

    Thank you in advance for the help. This has been driving me crazy for days.


  • The topic ‘Variations and New Product Save Issues’ is closed to new replies.