Support » Plugin: Pricing Deals for WooCommerce » Variation Name Across Products not work

  • Resolved marcocala100

    (@marcocala100)


    Hi, probably i don’t understand how it work, but i have difficult to set the field: “Variation Name Across Products”.
    I need of the discount to all products with attribute “Laura” and terms of this attribute “Arca”.
    I write “Laura | Arca” but this text not work…

    it is urgent…
    Can you help me please?

    Thank you
    Marco

    • This topic was modified 3 weeks, 6 days ago by marcocala100.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author vark

    (@vark)

    Hi,
    Please review these directions and experiment as indicated:

    Enter attribute names: use ” | ” to separate values ,
    ” + ” to combine values
    ( Changes To lowercase , removes leading and trailing spaces )
    If an Attribute Name has a space in the name between words,
    and the name is not found in testing,
    try replacing the space in the name with a dash “-”

    Best,
    Vark

    Hi, thank you for your reply.
    Could you tell me how to write the string correctly?

    Thank you

    Marco

    Plugin Author vark

    (@vark)

    Please supply screenprints from the front end of your store, showing the variation names you wish to select.

    Best,
    Vark

    thank you very much for your help.
    I make for you 3 screeprints:

    attributes page

    attribute and variation in plugin settings

    Inside the product

    best regards
    Marco

    Plugin Author vark

    (@vark)

    Hi,
    The rule looks fine relative to your supplied variations.

    You likely have a memory, caching or module conflict issue.

    I suggest the following:

    (A) Set your memory to a minimum of **512mb** , the de-facto memory standard (or greater!)
    (** Double-check ** the following, even if already set to 512mb.)
    (*) Memory should be *explicitly* set in *both* the php.ini (host) file,
    and in the wp-config.php file .
    – call your HOST to **Confirm or Set** the explicit setting of 512mb of memory in php.ini
    – update your wp-config.php file with a statement like this: define(‘WP_MEMORY_LIMIT’, ‘512M’);

    (B) Caching:

    Do you have a caching plugin (W3 Total Cache, etc)
    – If so, please **clear the caching plugin cache**. Test. **Turn off caching**.
    – ** close your browser completely, retest in a fresh, clean browser session **
    – If that isn’t it, carry on…
    (Pricing Deals is happy, however, with ** WP Super Cache: by Automattic ** , which seems to keep up better )

    (C) if that’s not it , it’s likely a conflict between my plugin and another module.
    Suggest a *full module conflict test*:

    To track down a module conflict, please follow these steps ** PRECISELY **:
    (1) Install and activate a maintenance mode plugin (if desired)
    (2) Then, DO ALL (*at the same time*):
    (-) do a full site backup!
    (-) deactivate ***all*** plugins except Woo, my plugin (and maintenance mode plugin)
    (-) ** switch to a clean default theme like “twentynineteen” **
    — (This removes all other possible conflicts.)
    (-) turn off all deals except the one we are examining.

    (3) ** close your browser completely, retest in a fresh, clean browser session **
    (4) if good, add 1 module back in. ** Retest **
    (5) Repeat until conflict identified.

    ** This test depends on following the outlined steps fully. **

    Best,
    Vark

    (PS – If you do have a module conflict, it will likely boil down to choosing between the 2 conflicting modules…)

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.