Support » Plugin: WooCommerce » Variable Products Won't Add To Cart

  • Resolved Corey


    When using a variable product the Add to Cart button and Quantity field cease to be displayed after you select the desired variable (i.e. Size) I’ve altered the CSS to make sure it gets displayed but then I am given the “Please choose product options” message.

    I have a selected price and all other required inputs for each variable yet it still doesn’t work. I’m thinking it could have something to do with the quantity selector of that could possibly not be going through.

    I’ve tried deactivating all plugins with no luck. But if I switch to a default theme it works fine so it must be a JavaScript issue with my modified Max Magazine theme. I’m relatively new at this and am currently holding up this client due to the problem. I have tried time and time again to uncover the issue but have had no real luck.

    Here’s an example page of a product to test it

    Any help would be fantastic for I have been dealing with this for over a month and I just can’t make any progress.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Well, the first thing I notice is that you’ve caused the add to cart button to always show. Is this the ‘altered the CSS to make sure…’ part that you refer to? This is a bad thing to do, since it will now show options to customers that are not ready to be used yet.

    I’ve tried to add that specific product to the cart, but I couldn’t figure out where the cart page is. Is that set (please check via WooCommerce > System Status in your administration panel)?

    Also, to rule everything them related out, can you please activate a default WordPress theme like Twenty Twelve so we can test without the theme affecting this behaviour?

    Well in that case will it not just return the same error I’m getting if the product isn’t ready to be added? I really just want it to be visible for aesthetic reasons.

    Cart can be found here:

    System Status page reads

    Cart: #311 – /shopping-bag/

    Not sure why that link at the top is refusing to update to the actual link, it seems to go on and off.

    And just because this is what I’m using as my test product now, refer to this because other product pages might be a little messy.

    Fixed the cart link issue

    Would you like me to hide the cart button again?

    I just find it more of a valid option to have it visible and return an error message than to not have it visible until you select options. The latter is clearly used much more frequently on e-commerce site, never encountered a hidden Add button until WooCommerce.

    But if there are errors outside of that which I am unaware of I have no problem reverting back to the default, especially if it’s just for your testing.

    Thanks for looking into this by the way!

    Well, if it’s just the fact that you prefer the ‘Add to cart’ button to be shown always, then that’s fine. I thought there was something else going on in my first pass, sorry.

    I’ve checked again right now and both products work fine. Is this resolved?

    Even if I had it hidden like it is set up to be it would never appear even when the variable (size) is selected.

    But yes, Steve Truman from helped me out.

    I know this is old, but how did you fix this? I have the same problem…



    Forum Moderator

    @hytare: If you require assistance then, as per the Forum Welcome, please post your own topic.

    @esmi I just did, thank you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Variable Products Won't Add To Cart’ is closed to new replies.