Support » Plugin: WooCommerce » Variable Products NOT added to cart

  • Resolved seriousfunk


    The Woocommerce ‘Add to cart’ button is not working for variable products. See here: Clicking the button refreshes the page but does not show the cart as it does for non-variable products. When viewing the cart,, the product has not been added.

    It appears this broke when I updated Woocommerce update to 2.1.7.

    I had to make a minor mod to wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart-variation.js so that the ‘Add to cart’ button would show up at all for variable products. But now that it shows up it does not work when clicked.

    Any ideas? Some suggestions I found online was to remove the themes /woocommerce/single-product/add-to-cart/variable.php but it doesn’t look like the ‘Elegant Themes’ Foxy theme I’m using is overriding the default variable.php file.

    Thanks for you help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • May actually have been the update to WP 3.9 that broke this. Still don’t have it working. Have tried most suggestions found online. Problem persists in Twenty Twelve theme. Problem also persists with all plugins except woocommerce disabled. Anyone have any ideas?

    I finally solved this. Another administrator had installed and then removed a plugin titled ‘woocommerce-variation-sorting’ that modified the woocommerce\templates\single-product\add-to-cart\variable.php file. It overwrote version 2.1.0 of the file with a modified version of 1.6.5.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Variable Products NOT added to cart’ is closed to new replies.