Support » Theme: OceanWP » variable products issue with “Samsung Internet” Browser on Android

  • Resolved raetseldetektive

    (@raetseldetektive)


    Hi,

    when using Webbrowser “Samsung Internet” on Android Device it is not possible to buy variable products on our woocomerce shop. It looks like this issue is new since oceanwp 3.0 update as we never got customer complains before. But now we had a couple of complaints within 2 weeks.

    Problem description: As soon as you select the “select option” field on your mobile “Samsung Internet” Browser is showing a popup with all options. You can select one option and after popup is closed, the selected option is shown on webpage, but “add to cart” button is still deactivated.

    Example Variable product: https://raetseldetektive.de/produkt/schnitzeljagd-die-raetselhafte-flaschenpost/
    Please try to add one of options of this product to cart using “Samsung Internet” Browser.

    There are to our knowledge no issues with Chrome and Firefox on Android and also no problems with Chromium, Firefox or Edge on Desktop PCs and also no issues with Safari Browsers on Apple devices

    Could you please have a look?

    Thanks a lot in advance,
    Andreas

Viewing 3 replies - 1 through 3 (of 3 total)
  • Abhishek

    (@abhikr781)

    Hello,

    Please go to Theme Panel > Scripts & styles, disable all the files click on the save button, now enable all the files, and click on the save button a couple of times, clear the entire cache, and check.

    PS- make sure to enable all the scripts & styles files.

    If you still experiencing the issue, please open a ticket at the helpdesk to take a closer look into the issue.
    https://docs.oceanwp.org/article/762-how-can-i-get-support

    Thread Starter raetseldetektive

    (@raetseldetektive)

    Hi Abhishek,

    disabling and re-enabling all scripts did not help.

    But I was able to solve the issue by disabling combine Java Script in “W3 Total Cache”. Issue is present when using “combine only” or “combine & minify” in Javascrip minify settings. Using “Minify only” or disabling JS minify at all is working fine.

    So sorry for opening this thread, seems like I used to aggressive speed optimization settings. But still strange, that such an issue is only present on “Samsung Internet” Browser, but not on other Chromium based browsers.

    BR, Andreas

    Abhishek

    (@abhikr781)

    Glad to hear that issue has been fixed and thank you so much for sharing the solution with us.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.