Support » Plugin: Secure Trading Gateway for WooCommerce » Validation Error when PayPal also enabled.

  • Resolved jamesmb85

    (@jamesmb85)


    We have just updated from version 2.0.4 to 2.0.8 and there is an issue when the PayPal gateway is also enabled.

    If the PayPal option is selected and ‘proceed to paypal’ button clicked 2 secure trading errors are displayed. ‘The expiry month you have provided is invalid’ and also ‘The expiry year you have provided is invalid’

    On submission of the PayPal option it seems to be trying to check for a valid date in the secure trading form even when this is not the payment method selected.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the same, also with stripe.

    Have disabled the plugin altogether now and I’m using stripe and paypal exclusively.

    The plugin does not check to see if it has been selected for payment. To fix this, add the following to line 58 of /secure-trading-gateway-for-woocommerce/assets/frontend/js/main.js

    if(('.payment_method_st_gateway').is( ':checked' )) {

    and a closing brace to line 75

    }

    The following can also be implemented in main.min.js but will require you to know what you are looking at.

    @idave2012 – superb, will try this next week.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Validation Error when PayPal also enabled.’ is closed to new replies.