Support » Plugin: NextGEN Facebook » Validation error: validation info doesn’t match preview on blog archive page

  • Resolved antonjazz

    (@antonjazz)


    Hello,

    I’m using NGFB to create all my opengraph metadata, by supplying the info & image on each page’s entry in the WordPress user interface.

    This works for every page in my site except the blog archive page, antonjazz.com/blog, which instead shows not its own title/description/image but rather that of the web site home page, antonjazz.com.
    NGFB displays the info I’ve entered for the blog page nicely on its own “Social Settings > Preview” tab, but info facebook shows me at “Social Settings > Validation” does not match that; it comes instead from the site’s Home Page.

    You can see this on the facebook debug page here: https://developers.facebook.com/tools/debug/sharing/?q=antonjazz.com%2Fblog%2F.

    Is there a way to prevent NGFB from overriding the blog archive page’s info & image?

    Thank you in advance!

    PS I noticed something on the forum involving a filter, but I’m thinking there must be a simpler solution, no?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    Your message is a bit confusing, so let me ask you a few questions to sort this out…

    The issue your having is on http://antonjazz.com/blog/, correct?

    Here is the title and description used:

    
    <meta property="og:title" content="Anton Schwartz - Jazz Saxophone"/>
    <meta property="og:description" content="Jazz saxophonist, composer and clinician based in Seattle and San Francisco. Latest CD &quot;Flash Mob&quot; &quot;★★★★&quot; -DownBeat"/>
    

    Is this correct, or not?

    This is an archive / blog page, not a static page, correct? So there’s no “Social Settings” metabox with a preview since this is not a “page”, but a collection of pages…

    Since there’s no image, can I assume that you haven’t selected a default image in the NGFB > General settings page?

    js.

    Plugin Author JS Morisset

    (@jsmoriss)

    Also, since this is the home page for your WordPress site, have you update the Site Name and Site Description values in the NGFB > General settings to use the text you want?

    You may want to review the Setup Guide and the NGFB > Essential settings page again…

    js.

    • This reply was modified 2 years, 9 months ago by JS Morisset.

    Thank you for the reply, JS.
    The title and description you give are the ones I have for antonjazz.com (the home page) but not the correct ones I want for antonjazz.com/blog.

    Have a look at the information I have entered for antonjazz.com/blog in the NGFB section of the WP control panel for the blog page:

    I have specified a title, description and featured image that I want, none of which are reflected in the og meta tags that are output for antonjazz.com/blog. How can I address that?

    thanks,
    Anton

    PS I am a registered Pro user but wasn’t able to find the Pro support when I was in need of help. I see it now at http://support.surniaulula.com/support/home – let me know if I ought to move the conversation there…

    Plugin Author JS Morisset

    (@jsmoriss)

    Yes, you should open a ticket on the Pro support website. The wordpress.org forums prohibit supporting Pro versions. For future reference, the Pro support website link is located at the top of every settings page, at the top of every webpage on the surniaulula.com website, and in the email you received after purchasing. 😉

    Your setup is a bit confusing – it sounds like you’ve defined a static page under the WordPress Settings -> Reading as a “Posts page”, but you expect it to behave as a static page as well, not an archive page. I’m not sure WordPress provides a post ID under these conditions – I’ll have to check on a test site. Open a ticket an I’ll follow-up there.

    js.

    Thank you, JS – I just created a ticket.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Validation error: validation info doesn’t match preview on blog archive page’ is closed to new replies.