WordPress.org

Forums

Crayon Syntax Highlighter
[resolved] Validation error (4 posts)

  1. rtomo
    Member
    Posted 2 years ago #

    Hy!

    When i'm trying run the W3C validator, show that error:

    Bad value off for attribute wrap on element textarea.
    
    …size:4; tab-size:4; font-size: 12px !important; line-height: 15px !important;">

    What is the problem?

    Link for validator error message:

    Thx!

    http://wordpress.org/extend/plugins/crayon-syntax-highlighter/

  2. rtomo
    Member
    Posted 2 years ago #

    The link on the "Thx!" text, because i don'i closed tha link tag.

  3. akarmenia
    Member
    Plugin Author

    Posted 2 years ago #

    I've discussed this during the 1.9.0 release and mentioned there is no cross browser way to achieve this using CSS other than either using the wrap tag or setting the wrap tag with JavaScript. The latter would render your markup "valid" but would have exactly the same effect, with the side-effect that if that bit of the script failed the rest of the script would halt. Due to this I believe it's the best solution so far. Also, while Chrome did not need the wrap=off, Firefox did. In any case, I'm sure no kittens will be harmed.

    http://stackoverflow.com/questions/657795/how-remove-wordwrap-from-textarea

  4. christopherdubeau
    Member
    Posted 1 year ago #

    I think may have fixed the issue: change the wrap="off" to wrap="soft" in the crayon_formatter.class file.

    Seems to work with ie, firefox, safari and chrome.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Crayon Syntax Highlighter
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic