Support » Plugin: Limit Login Attempts Reloaded » ‘valid_duration’ got set to 1

  • Hi,

    After I upgraded following a conversation with @wpchefgadget last week, The plugin began giving me unlimited attempts to login. I added some debugging and I noticed that the ‘valid_duration’ option was set to 1.

    I don’t see any UI to update this, although from looking at some of the commented out code I bet it existed at one time, or is planned.

    In any case, I think the sanitize_options() function was a little overzealous — it sets numeric options to 1 if they have non-int values. I’d recommend changing this function to set values to the default settings if they are garbled, especially for options that don’t have any UI. I have to fix this on a server I don’t have access to, which is fine for me (I can write some code to do it) but that might be difficult for others.

  • You must be logged in to reply to this topic.