WordPress.org

Support

Support » Plugins and Hacks » Contact Form 7 » Valid URL gives "URL seems invalid"

Valid URL gives "URL seems invalid"

  • This is just a heads-up for the developer of a URL which is being misidentified as invalid when the form is submitted.

    http://wis-wander.weizmann.ac.il/weather-on-the-outer-planets-only-goes-so-deep/

    I’m guessing it’s something to do with the number of levels in the domain maybe combined with the dash in the “wis-wander” subdomain.

    http://wordpress.org/extend/plugins/contact-form-7/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Takayuki Miyoshi

    @takayukister

    The URL is valid. I didn’t see validation error when I tested it on my environment.

    Hi, thanks for replying 🙂

    Strange, it definitely fails to validate on mine. If I remove the dash from “wis-wander” then validation is successful.

    I’ve tested in Firefox 20.0.1 and Google Chrome 26.0.1410.64 m and get the same result.

    I’m using Contact Form 7 version 3.4.1 on a WordPress 3.5.1 installation with the default jQuery 1.8.3, and jQuery UI Core 1.9.2

    Plugin Author Takayuki Miyoshi

    @takayukister

    Can I see the site? Also, what plugins and theme do you use?

    Plugin Author Takayuki Miyoshi

    @takayukister

    What version of PHP do you use? If possible, try upgrading it to the latest version. There seems to be a PHP bug relating to this.

    Yes that’s no problem, but could I send the details to you privately?
    We’ve had some directed attacks to our server in recent months and I’d prefer to keep the server details from being easily found in public if possible.

    Plugin Author Takayuki Miyoshi

    @takayukister

    That’s OK if it’s difficult to be public. Just try upgrading PHP.

    I’m currently using a shared server so unable to update PHP, however I also have a local development box with xdebug so will do some testing on there along with disabling plugins, etc.

    I’ll let you know what I find 🙂

    Everything was fine on my development box (PHP 5.4.6-1ubuntu1.2), and the validation passed.

    The PHP version on the live server where the validation fails is 5.3.2-1ubuntu4.19

    I’ll see if I can get the shared hosting updated to a more recent version of PHP.
    Thanks for your help 🙂

    Where can I find the validation code? I’d like URLs both with and without http:// to be valid.

    truck808

    @truck808

    Hi. I’m having a problem where http://www.domain.com seems invalid but https://www.domain.com works fine. Any way around this?

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Valid URL gives "URL seems invalid"’ is closed to new replies.
Skip to toolbar