Support » Plugin: Business Directory Plugin » Valid URL format required message appearing for non-required fields

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author businessdirectoryplugin


    Deleting the fields will indeed delete the data. You probably don’t want to do that.

    Can you tell me what your field settings are for one of these fields? A screenshot may be best. Use if you need to.

    Also, what version of BD are you running?

    Hiya, I’m running the newest version of BD, in fact this has only started happening after the recent update.

    It also seems that these fields are now also showing up in my listings if left empty, where before they used to only show up if they were filled in.

    The field settings for all those fields are the same: post metadata; textfield; URL validator; open in new window; Display this value in the listing view. The other check boxes are left blank (including ‘this field is required’ which is why this is so confusing!

    I’ve turned them all the ‘no validation’ and now they’re fine so if definitely something to do with the URL validation setting.

    Hiya, this isn’t actually resolved, I want them to be URL’s so is there anything that can be done to make this possible?

    Plugin Author businessdirectoryplugin


    I’ve submitted this to my developer and we’re looking into it.

    Part of the issue I think is the introduction of the link text in 2.1.5, which seems to not gracefully handle prior links on upgrade. We have a fix for that coming shortly. But we’ll get the validator one as well.

    Marking something as “resolved” just means to me that I’ve handled it. If you have more questions, feel free to ask in the thread, I’ll keep answering. 🙂

    Hi. My issue is with another “Required” Field. On my site: I changed the name of the field “Long Business Description” for “More Camp information” and want this field NOT to be required (Free listing doesn’t get this option). But it won’t let me make it “Not Required” ever since I updated to the latest version. Same with the”Contact e-mail” How can I fix that? I tried going in the Directory Admin> Manage Form fields and click on “Not Required” but it won’t work!

    Any help would be greatly appreciated.

    Plugin Author businessdirectoryplugin


    Hi magda,

    I’m answering this in the other thread, since it’s not the same issue as before.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Valid URL format required message appearing for non-required fields’ is closed to new replies.