WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Valid feed but error

[Resolved] Valid feed but error

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Allen

    @amweiss98

    Hi,
    The feed looks fine as I was able to read it using my plugin. The error you are getting means that the wordpress rss reader (called simplepie, which is what my plugin uses) is unable to read the feed. The fact that this worked on one domain and not another (did you change web hosting services) suggests the problem resides with the server your web site is on. It may be blocking getting RSS feeds, or as one user found out when they did some checking they found out the error was this:

    RSS Error: WP HTTP Error: There are no HTTP transports available which can complete the requested request.

    Again, this is a problem with the web hosting company. So, the first question is whether you switched hosting companies when you changed domains…or did you not change hosting companies but you are now on a different server?

    Hi Allen,

    Thanks for the quick reply.

    Yes, the moving included switching hosting company.
    Do you know if “RSS Aggregator” use the same “simplepie”?
    That plugin was working on the old server as well as the new one.
    On the old server both plugins was installed at the same time and running fine.

    The reason why we are running two different RSS plugins is that, we want to show two different numbers of feeds on different pages.

    Plugin Author Allen

    @amweiss98

    yes, RSS Aggregator also uses simplepie. Right, but you can use my plugin on different pages, showing different number of feeds on different pages.

    Then there must be an error somewhere in the RSS Multi Importer. Any suggestion how I can troubleshoot?
    Please keep in mind that I am not that proficient in php.

    Plugin Author Allen

    @amweiss98

    I’m not sure why say there is an error in my plugin. Unless you tell me the error I can’t determine what is going on, especially since I don’t have any of the 14000 other people who downloaded the program who have told me there is an error.

    Well, in other words – its not working as it should (and did on the other server), and I am only interested in trying to find a solution.
    As the other RSS plugin is working jumping to the conclusion that simplepie was not to blame was close.
    Any suggestions how I can troubleshoot further to find the source of the problem?

    Plugin Author Allen

    @amweiss98

    ok..let’s try this…does your theme allow you install the wordpress RSS widget (it comes with most themes and is a generic widget..you can see it here

    https://dl.dropbox.com/u/3132388/screenshot_426.jpg

    put the rss feed into that widget and see if that works..that there is no error, etc.

    Since that widget that is embedeed in wordpress also uses simplepie, then if that works there is something else going on..and I’ll look to see what that might be.

    Hmmm that worked without any issue.

    Plugin Author Allen

    @amweiss98

    ok…then let’s do this…send me an email to me@allenweiss.com so I can reply with instructions on what to try next.

    I will do that. And thanks Allen for be so persistence to find a solution. I really appreciate it!

    Plugin Author Allen

    @amweiss98

    also, while you’re doing that, I’m wondering if you could try getting rid of the https: at the beginning of your rss feed…that is use this:

    http://www.webcruiter.no/webservices/webcruiterculture.asmx/RSSFeed?company_id=1234782315&CultureId=DA

    and see if that changes anything..thanks

    GREAT!

    That was apparently exactly the problem. Why did I not think of trying that???

    It’s working!

    Thanks for all your help. It was beyond excellent!

    Expect a little donation a few days from now 🙂

    Plugin Author Allen

    @amweiss98

    actually, don’t worry about a donation, just rate my plugin by going to
    http://wordpress.org/extend/plugins/wp-rss-multi-importer/

    I think the problem is probably that your server doesn’t want to go fetch data from secure sites (https)..I’m going to see if the other plugins strip out the https and that’s why they work when mine hasn’t stripped them out.

    I will do both! Hope you don’t mind 🙂

    You are probably right. And thinking of it, it’s kind of silly using secure socket when RSS broadcasting job offers.

    But really great that you will look into it.

    BIG thanks!

    Plugin Author Allen

    @amweiss98

    Also, who do you use for a web hosting company as I may take out a monthly plan there to see if I can reproduce the problem..it would be much easier to fix if I can get the problem myself. Thanks.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Valid feed but error’ is closed to new replies.